Lightroom: 3.6/4.0/4.1rc Red Eye point moves down and right when adjusting with arrow keys

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
Red eye tool in LR 3.6, LR 4.0, LR 4.1rc. When attempting to adjust an established red eye point in any of these versions of LR by using the keyboard arrows (left, right, up, down one pixel at a time for fine control) the point always adjusts down and to the right regardless of what direction is pressed on the arrow keys. Expected behavior: Established red eye point moves one pixel in the direction of the arrow pressed.
Photo of Jason Passmore

Jason Passmore

  • 2 Posts
  • 0 Reply Likes
  • bothered

Posted 6 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Hi Jason,

What OS are you on? Just tried with Mac OS 10.7.3 and it seems to work as expected.
Photo of LRuserXY

LRuserXY

  • 426 Posts
  • 41 Reply Likes
Works as expected on Win7 64 bit, with LR 4.1 RC and LR 3.6 (64 bit). Tested using the dedicated arrow key as well as the numeric keypad with numlock off - no problems.

Perhaps a keyboard driver issue, some incompatibility with LR? Or some problem with a utility such as a hot key utility or the like?

I use the standard keyboard drivers of Win7 and no additional utilities. It is a non-cordless :-) USB keyboard by Cherry.
Photo of Jason Passmore

Jason Passmore

  • 2 Posts
  • 0 Reply Likes
I'm using Win 7 64 bit on a Dell XPS laptop (unfortunately I'm traveling and don't have another computer to test with) for all versions of LR. No keyboard utilities are installed, and the result is the same using the standard arrow keys and number keypad (NumLock off). I also tried a USB keyboard (cheap Logitech basic keyboard), both keyboards react the same when it's plugged in, laptop keyboard is the same with USB keyboard unplugged. Additionally, using ALT+ any arrow key (and num pad) results in the red eye spot always increasing size, never decreasing.

It seems to be ONLY the red eye function. Using the Spot Removal tool with either source or destination circles, both move correctly, and adding ALT increases or decreases with up and down arrows.

I can't find any other functions in LR or outside of LR that are affected.

Any other suggestions or steps to try? It would seem that it's related to something specific with my laptop and the red eye tool, but I'm clueless as to why. I've had the laptop for just under a year and this is probably the first time I've used the red eye tool.