Lightroom: 'Open as Layers' in Photoshop doesn't work

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Hi!...brand new here (great forum). I currently use LR 4.1 and Creative Suite 5.5 (and this question only relates to the Photoshop install) on a new MacBook Pro with Maverick. Here is my question: when I want to transfer a couple images into PS (say, to focus stack), PS does not open....I can transfer one image into PS...but cannot send two or more images into PS...it simply opens as a shell only- with no photos.
If someone here can help me, I'll send Xmas cards....lol
Photo of Darren Hebert

Darren Hebert

  • 2 Posts
  • 0 Reply Likes
  • confused

Posted 3 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1735 Reply Likes
Hi Darren, did it ever work on this system? Did you do a clean install of your software on the new computer? Or move the software over another way?
Photo of Darren Hebert

Darren Hebert

  • 2 Posts
  • 0 Reply Likes
Hi Jeff...thanks for getting back to me. It never did work, and I believe I simply installed both LR and PS (from disc) cleanly. I read from other forums that a Java script may need updating...did that with no improvement too.

Thanks Jeff!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1735 Reply Likes
I would make sure both Photoshop and Lightroom are up to date by selecting Help>Updates... and installing available updates.

Then I would restore Photoshop's preferences and restart both PS and LR: http://blogs.adobe.com/crawlspace/201...
Photo of Vibeke

Vibeke

  • 3 Posts
  • 0 Reply Likes
Mine used to work. I have just unistalled PS through Creative cloud, keeping my settings, and Hurray, it now works again.
Photo of Walter Stafford

Walter Stafford

  • 3 Posts
  • 0 Reply Likes
I also have the same problem: I have updated both LR and PS to CC 2015 latest versions. "Open as layers in Photoshop" worked with the previous version of PS and LR CC 2015 but now I cannot "open files from LR as layers in PS" after the latest update. Hoping for fix for this. Loading them and pasting them in layers one-at-a-time is a pain.
Photo of Walter Stafford

Walter Stafford

  • 3 Posts
  • 0 Reply Likes
I should add: I have deleted my preferences as per instructions above,and it still doesn't work.
Photo of Walter Stafford

Walter Stafford

  • 3 Posts
  • 0 Reply Likes
I was just asked by CC to update CC to version "Version 2.1.3.121 released on 7/7/2015" and now afterwards I am able to Open Lightroom photos as layers in Photoshop. Happy now.
Photo of Jose Suro

Jose Suro

  • 1 Post
  • 0 Reply Likes
I have the same problem as Walter on a new Macbook Pro and I am running the latest version of CC. I did find out that I can open to layers any images from any network drive but It wont work if the images are on my Macbook SSD drive.
Photo of BILL OXFORD

BILL OXFORD

  • 1 Post
  • 0 Reply Likes
I opened a support ticket in January about this issue.On January 26, 2016 Adobe tech, Himanshu Bisht contacted me and logged into my MAC in order to determine the problem. He adjusted the Preferences in Photoshop for Performance for Graphic Processor Settings. This solved the problem for about a day then it came back where when exporting from LR by EDIT IN > OPEN AS LAYERS IN PHOTOSHOP only one layers opens and the second layer is blank. This happens on large and small files. 

What is odd, is that this malfunction is not consistent. If I Quite Photoshop and restart, it will load layers fine. After working for a while exporting from Lightroom, it will again, malfunction. This also happens when Exporting to HDR PRO IN PHOTOSHOP.

My system is MAC Pro Tower, 12-Core with 62 gb Ram, running OS X Yosemite 10.10.5 (latest). Himanshu said it was the strongest Mac he had worked on. My main HD is SSD drive so perhaps that could be an issue as Jose mentioned.