Lightroom Classic: Not responding and crashing every time

  • 3
  • Problem
  • Updated 2 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom Classic 7.3: Unresponsive after Eject SD Card/USB Drive

I'm a paid LR/PS subscriber and updated the software yesterday after it kept on crashing after every import and during the import process itself. I've restarted the PC several times, it opens up and then it freezes again.  Crashing continues and Adobe says I'm using LR and PS in trial mode. Very dissapointed!
Photo of Jorge Restrepo

Jorge Restrepo

  • 2 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 3
Photo of Prabal Ghosh

Prabal Ghosh, MTS II

  • 5 Posts
  • 0 Reply Likes
Hi Jorge,
Which OS are you using?
Are you importing from any external device (like sdcards,phones) or from local filesystem?

Thanks,
Prabal Kumar Ghosh
Photo of Jorge Restrepo

Jorge Restrepo

  • 2 Posts
  • 0 Reply Likes
I use windows 10, HP PC, importing from an SD card, and after crashing from there, I also saved the files on to my hard drive and imported from there and also crashed.  Really sucks!

And, why is my license a trial license?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Try signing back in. From Lightroom, select Help > Sign-In... or go to the Creative Cloud desktop app and sign in.

The issue with SD cards is a known issue.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1410 Posts
  • 434 Reply Likes
Can you post your Lightroom>Help>System Info...? 

This conversation is no longer open for comments or replies.