LR mobile: thumbnails not showing

  • 1
  • Problem
  • Updated 9 months ago
I use multiple Android devices, on one  LR mobile is not showing the thumbnails after half a day. They just disappear, all of them.

If I open the photo for editing the photo is shown, the slideshow shows photos too, if its a newly imported photo (from this device or another) the thumbnail shows a few hours and then its gone.

The preview album and people thumbs are also gone.

Uninstalling LR mobiles, deleting all folders, rebooting and clearing ART cache then reinstalling doesn't change anything.

Different settings for just load SMART previews or download the whole files don't change anything.

Its happening on Android 9, but works without any problems on my other Android 9 devices.

Sucks because it makes editing the right photo hard if I can't see what it is, after all I'm paying for this.
Photo of Donna Wetter

Donna Wetter

  • 104 Posts
  • 10 Reply Likes

Posted 9 months ago

  • 1
Photo of Arnab Sil

Arnab Sil, Employee

  • 49 Posts
  • 12 Reply Likes
Hello Donna,

Can you please check that do you have any disk cleaner app/optimizer running on your device which has the thumbnail issue?

Regards,
Arnab
Photo of Arnab Sil

Arnab Sil, Employee

  • 49 Posts
  • 12 Reply Likes
If thumbnails are getting cleaned up after a particular interval, we highly suspect that a disk cleaner or optimizer is involved in the scene as Lightroom does not do that. The disk cleaner need not to be a third party app installed by you but it can be a manufacturer provided one as well.

Can you please confirm what device you have and did you ever saw Lightroom behave normally on your device (since you bought the device on which Lightroom has trouble)?
Photo of Donna Wetter

Donna Wetter

  • 104 Posts
  • 10 Reply Likes
Actually I found an automatic optimization thing that says it would delete files, in the settings. Turned off and will reset LR and see if that was it..
Photo of Arnab Sil

Arnab Sil, Employee

  • 49 Posts
  • 12 Reply Likes
Please check for a day and let us know if you still see the issue. Hopefully this should be the only optimizer available on your device. :)

Regards,
Arnab
Photo of Donna Wetter

Donna Wetter

  • 104 Posts
  • 10 Reply Likes
Seems it was the "automatic optimization" built into the ROM, thanks for pointing me in the right direction.

Also strange only LR is affected by this, must be an odd place where the thumbnails are stored, that something like this gets them removed, also LR could notice that and just recreate them.
Photo of Arnab Sil

Arnab Sil, Employee

  • 49 Posts
  • 12 Reply Likes
Glad to hear that your issue is resolved with the suggested workaround.

Just to clarify your doubts - Lightroom places its thumbnails in a the standard location as per Android guidelines. But as android is not strict about few other guidelines, few disk optimization utilities start clearing off bigger sized files from everywhere (even from other app's directory) leading to this issue.

We are aware of this issue and we will evaluate this with other backlog items according to the field reports.

Regards,
Arnab