Lightroom: Crashing when sync setting in images within groups

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
LR 2015.7 is crashing when the settings of one image within a group of images is synced with an individual images within more than one group of other images.  Happens all the time.  (e.g. three groups of images each containing two images. adjust exposure and contrast in the first then highlight the other two that are in different groups and the program blows up)
Photo of Barney Koszalka

Barney Koszalka

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1381 Posts
  • 408 Reply Likes
That is not good. Windows or Mac? Is there a crash log generated? If you are on Mac, you can submit the crash log directly to Adobe via the Adobe Crash Report dialog. Make sure to note down your email address. Is the crash photo specific?

Can you also provide a screenshot of your synced collection structures? 
Photo of Barney Koszalka

Barney Koszalka

  • 3 Posts
  • 0 Reply Likes
Good question and something I should have included: iMac operating with Sierra OS.  I submitted the crash report to Adobe along with my email.  Don't know about it being image specific.  This was a simple group of 3 images that I made virtual copies of which generated the three groups.  The virtual image in the first was altered (exposure and contrast) and the other virtual copies highlighted to sync the changes.  Hit sync and boom...
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1377 Posts
  • 408 Reply Likes
Is this a new issue that you run into in Mac OS X 10.12.1? Does it happen in Mac OS X 10.12? Based on the crash log, it seems to crashing somewhere deep inside the Mac OS X API which we know there has been some changes in Sierra (we've seen other related bugs). Can you try to reset the Lr user prefs (hold Option+Shift keys down when launch Lr?

I have tried to follow what I understand are your steps to produce the crash. I could not on Mac OS X 10.11.6
(Edited)
Photo of Peter Stott

Peter Stott

  • 2 Posts
  • 0 Reply Likes
Since updating to Sierra, I have found that Lightroom crashes more often than not, simply on opening. I will submit the crash report to Adobe.
Photo of Arjun Haarith

Arjun Haarith, Employee

  • 80 Posts
  • 22 Reply Likes
Hi Barney,

As per my understanding on the steps you provided, this is what I did.
1) Created three virtual copies for an image (tried for Raw and Jpeg images as well)
2) Applied exposure and contrast changes for one of the VC
3) Selected all the virtual copies and synced the settings.

I tried both the options (Sync settings in Library module , Sync in develop module)
However, I am not able to reproduce the crash.
Please let me know if this is what even you were trying out.
Is this is happening all the time ?

I tested this on : 
Lr 6.7
Mac OS 10.12 (Sierra)

Thanks,
Arjun