Lightroom Classic v9.1: Book Module: Export to PDF hangs/never completes; some pages are blank

  • 1
  • Problem
  • Updated 5 months ago
  • Solved
  • (Edited)
Lightroom Classic v9.1 on MacOS Mojave 10.14.4

Trying to export a book to PDF. 13x11 size, no cover. PDF will be created with most pages, but pages using specific custom pages are skipped/left blank. In LR, the progress bar still says "exporting book to PDF," and that process is never completed. 



I made a copy of the book and eliminated all pages except the two problem pages. Same result, cannot export those two pages to PDF, progress never completes.

I changed the images for those two pages. Same result.

I changed those two pages to use one of LR's templates and different images. The PDF now includes actual pages (not blank ones), but the process never completes. 

I exported this book to a new catalog. Tried different PDF settings (quality, color space, etc). I deleted preferences. Deleted all custom templates I created. Rebooted. Etc. Problem persists. 

I CAN, however, export this book to JPEG, but that is a more time consuming workflow. 

Does anyone have any other recommendations?

Using custom layouts:




Using LR's own default page layouts:

Photo of LM

LM

  • 3 Posts
  • 1 Reply Like
  • frustrated

Posted 5 months ago

  • 1
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 90 Posts
  • 36 Reply Likes
Hi LM,

Thanks for reporting the issue. We are able to replicate the issue and bug is logged for the same. The issue is specific to "No Cover". The same page template is working fine with other cover types.

-Mayuri
Photo of LM

LM

  • 3 Posts
  • 1 Reply Like
So I'm not crazy! I'm actually pleased to know this is a bug. There must be something wrong with my custom layouts, because I recreated them and I am able to get those pages to build. I did a test PDF export with a blank cover and the entire process finishes as expected now. 

Looking forward to a new release to fix this bug. Thanks
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7535 Posts
  • 1725 Reply Likes

Updates to Lightroom Classic, Camera Raw, and the Lightroom Ecosystem were released yesterday and contain a fix for this issue.  Please install the appropriate update and see if it solves this problem. You can read more about the updates here.

Thank you for your patience.