Lightroom Classic: Some keywords not in alphabetical order

  • 6
  • Problem
  • Updated 1 year ago
  • In Progress
  • (Edited)
Since I have updated to LR Classic, I have an issue with my keyword list. I have hierarchical keywords. Some on the top level are numbered and some of the top level have no child keywords. Since the update the keywords on the top level and the second level hierarchy are no longer in alphabetical order. Some keywords seem to be ordered correctly, but several others are not. The keywords which are not ordered alphabetically seem to get ordered by a change/creation date or so.

I do not use LR CC and have not done any keyword changes on my mobile devices.

Has anybody an idea, what I could do about it? Is there I setting, I have missed?
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes

Posted 2 years ago

  • 6
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1932 Posts
  • 803 Reply Likes
Do you use a Macintosh running High Sierra? Update to Lr Classic 7.01. The update fixes a problem with the sort order of several lists.
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
I use macOS High Sierra (latest release) and have updated to LR 7.0.1 when it was released. This update has not fixed my issue with the keywords.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4272 Posts
  • 1137 Reply Likes
Please do Help > System Info and report the exact version number. (The LR update mechanism is unreliable and often fools people into thinking they're on "the latest".)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 513 Reply Likes
Try reset the Lightroom preferences to see if it is helpful.
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
@John: Yes, I can confirm that my version number of Lightroom is 7.0.1. For macOS it is 10.13.1.

@Simon: Can you please give me some advice how to do the reset and what "collateral damage" might happen?
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
Thanks for the link. I will test resetting the preferences over the weekend and report back.
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
I reset the preferences, but it had no effect. The some keywords are still not sorted alphabetically. 

But I had a deeper look into which keywords are effected: just 3 keywords. Two keywords starting with an "Ü". If I change that to "Ue" the keywords get sorted properly. Switching back to "Ü" make them appear again on the top of the list. That just happens for "Ü" but not for "Ä". I have made a new keyword starting with "Ö" and it is sorted between "abstrakt" and "Ähre" - somewhere in the middle of keywords starting with "a". Looks like an encoding issue or something like that, but it is unusual that it only effects all characters (umlaut).

I tested the behavior with the umlaut (Ä, Ö, Ü) on a second Mac and its the same on that machine too. I use the German version of Lightroom with a German keyboard layout.

The 3rd keyword is a top level keyword and starts with "06 ...". It is listed after keyword "08 ..." and I have no idea why. I have 8 such keywords (01 ..., 02 ..., 03 ..., 04 ..., 05 ..., 06 ..., 07 ..., 08 ...) and only 06 behaves different. Even changing the keyword from "06 ..." to "01..." does not effect the sorting. If I change keyword "08 ..." to "09 ..." it is still listed before "06 ...". If I remove the number 06, then the sorting is correct. 
(Edited)
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
I reset the preferences, but it had no effect. The some keywords are still not sorted alphabetically. 

But I had a deeper look into which keywords are effected: just 3 keywords. Two keywords starting with an "Ü". If I change that to "Ue" the keywords get sorted properly. Switching back to "Ü" make them appear again on the top of the list. That just happens for "Ü" but not for "Ä". I have made a new keyword starting with "Ö" and it is sorted between "abstrakt" and "Ähre" - somewhere in the middle of keywords starting with "a". Looks like an encoding issue or something like that, but it is unusual that it only effects all characters (umlaut).

I tested the behavior with the umlaut (Ä, Ö, Ü) on a second Mac and its the same on that machine too. I use the German version of Lightroom with a German keyboard layout.

The 3rd keyword is a top level keyword and starts with "06 ...". It is listed after keyword "08 ..." and I have no idea why. I have 8 such keywords (01 ..., 02 ..., 03 ..., 04 ..., 05 ..., 06 ..., 07 ..., 08 ...) and only 06 behaves different. Even changing the keyword from "06 ..." to "01..." does not effect the sorting. If I change keyword "08 ..." to "09 ..." it is still listed before "06 ...". If I remove the number 06, then the sorting is correct. 
Photo of John R. Ellis

John R. Ellis, Champion

  • 4272 Posts
  • 1137 Reply Likes
This person reported their Greek keywords were missorted on LR 7.0.1 / Windows 10 but not on the "previous" version of LR (previous was not defined):
https://forums.adobe.com/message/9927630#9927630
Photo of John R. Ellis

John R. Ellis, Champion

  • 4272 Posts
  • 1137 Reply Likes
I confirm that those umlaut characters seriously confuse LR's keyword sorting.   Here's an example from my LR 7.0.1  on Mac 10.12.6 and then Windows 10:




Without those umlaut characters present, LR appears to properly sort keywords with numbers:

Photo of ABHISHEK KUMAR

ABHISHEK KUMAR, Employee

  • 38 Posts
  • 17 Reply Likes
Official Response
@tpnotes: Try adding following config to config.lua:
LibrarySort.useOldSort = true

To locate the config.lua, Open Lightroom > Preferences > Presets 
Click on "Show Lightroom Presets Folder..."
It should take you to folder ending with ... /Application Support/Adobe/Lightroom/

If config.lua is already present in Lightroom folder, just add, 
LibrarySort.useOldSort = true
in the config.lua file. If the file is not present create a file named config.lua and add the same configuration there.

Let me know if it works.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4271 Posts
  • 1136 Reply Likes
Excellent, that fixes my test case:

Photo of Pantelis Cherouvim

Pantelis Cherouvim

  • 1 Post
  • 0 Reply Likes
Adding that setting in config.lua solved my problem (Greek keywords). Thanks a lot.
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
I store my presets with the catalog and the fix you suggested did not work, when I put the config.lua file (I did not have one before) in that folder. But when I put it at ... /Application Support/Adobe/Lightroom/ it worked.
Photo of Roman Sandoz

Roman Sandoz

  • 25 Posts
  • 2 Reply Likes
I have the same problem
- I tried creating a config.lua file (though I'm not sure if I did it right... on a Mac i created a Text file and just renamed it to config.lua - would that work?)
- I only have Folders in the Lightroom folder - you want me to just put the file in there by itself or would it also have to go into a folder?

It still looks the same:
(Edited)
Photo of ABHISHEK KUMAR

ABHISHEK KUMAR, Employee

  • 38 Posts
  • 17 Reply Likes
By default there would be no files inside the ../Lightroom/ folder. You should put the config.lua with the config added to it and put it there.
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
I just created a normal .txt file, named it config.lua and saved it here: Library/Application Support/Adobe/Lightroom/ (not in any of the subfolders). That worked for me.
Photo of Roman Sandoz

Roman Sandoz

  • 25 Posts
  • 2 Reply Likes
OK, tried that - didn't work...
Photo of John R. Ellis

John R. Ellis, Champion

  • 4271 Posts
  • 1136 Reply Likes
Verify that you correctly created Config.lua.  Do Help > System Info and look for this:
Config.lua flags: 
LibrarySort.useOldSort = true
If you don't see that, then you haven't got a correct Config.lua.
Photo of Roman Sandoz

Roman Sandoz

  • 25 Posts
  • 2 Reply Likes
Hmm... seems it's not correct, since it shows:

Config.lua-Flags: None
Photo of Roman Sandoz

Roman Sandoz

  • 25 Posts
  • 2 Reply Likes
Though I cannot figure out what's wrong:



Photo of John R. Ellis

John R. Ellis, Champion

  • 4271 Posts
  • 1136 Reply Likes
It looks like you used TextEdit and saved it in the default format, which is "rich text".  You need to save it as plain text.  Best to start from scratch.   In TextEdit:

1. File > New

2. Format > Make Plain Text

3. Enter the line "LibrarySort.useOldSort = true" and be sure to hit Return at the end, so the input cursor (the blinking bar) is under "L".

4. File > Save.  Save As: Config.lua. Plain Text Encoding: Unicode (UTF-8).  Save.  Use .lua.
Photo of Roman Sandoz

Roman Sandoz

  • 25 Posts
  • 2 Reply Likes
@John R. Ellis: perfect, thanks - it works! (That's probably why it says "Champion" next to your name in the first place ;-) )
Photo of Yves Crausaz

Yves Crausaz

  • 341 Posts
  • 49 Reply Likes
This reply was created from a merged topic originally titled Sort keywords in alphabetic french order !.

Sort keywords in alphabetic order french!

E....
e.....
é......




In this example, it's wrong!
Photo of Yves Crausaz

Yves Crausaz

  • 341 Posts
  • 49 Reply Likes
Ok, bonne solution: John R. Ellis, Champion
Photo of Roman Sandoz

Roman Sandoz

  • 25 Posts
  • 2 Reply Likes
Not fixed in release 7.1... (still requiring the config.lua file)
(Edited)
Photo of tpnotes

tpnotes

  • 57 Posts
  • 7 Reply Likes
Can someone from Adobe confirm, that this topic is acknowledged as a bug and will be fixed in an upcoming version of Lightroom Classic?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15365 Posts
  • 2239 Reply Likes
Official Response
This is an open issue that engineering is investigating.
Photo of Roman Sandoz

Roman Sandoz

  • 25 Posts
  • 2 Reply Likes
((Upgrade to Mac OS High Sierra 10.3.2 didn't help either))
(Edited)
Photo of SCHAEPPI HANS RUDOLF

SCHAEPPI HANS RUDOLF

  • 25 Posts
  • 5 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic: Keyword list issue.

After updating from LR 6 2015 CC to LR Classic 7.1 CC the order of the keyword list does'n work properly anymore even in the .txt file the order is correct like in LR 6 2015. No chance to reorder this list until now. The problem is already known for a long time, but not solved until now.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4272 Posts
  • 1137 Reply Likes
In the original topic, Schaeppi reports that the workaround above has solved the problem for him.