Lightroom Classic: Some keywords not in alphabetical order

  • 6
  • Problem
  • Updated 2 months ago
  • In Progress
  • (Edited)
Since I have updated to LR Classic, I have an issue with my keyword list. I have hierarchical keywords. Some on the top level are numbered and some of the top level have no child keywords. Since the update the keywords on the top level and the second level hierarchy are no longer in alphabetical order. Some keywords seem to be ordered correctly, but several others are not. The keywords which are not ordered alphabetically seem to get ordered by a change/creation date or so.

I do not use LR CC and have not done any keyword changes on my mobile devices.

Has anybody an idea, what I could do about it? Is there I setting, I have missed?
Photo of tpnotes


  • 35 Posts
  • 5 Reply Likes

Posted 5 months ago

  • 6


  • 33 Posts
  • 12 Reply Likes
Official Response
@tpnotes: Try adding following config to config.lua:
LibrarySort.useOldSort = true

To locate the config.lua, Open Lightroom > Preferences > Presets 
Click on "Show Lightroom Presets Folder..."
It should take you to folder ending with ... /Application Support/Adobe/Lightroom/

If config.lua is already present in Lightroom folder, just add, 
LibrarySort.useOldSort = true
in the config.lua file. If the file is not present create a file named config.lua and add the same configuration there.

Let me know if it works.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13635 Posts
  • 1546 Reply Likes
Official Response
This is an open issue that engineering is investigating.