Lightroom Classic: Problem with previews during import for large volume/slower than LR CC2015.12

  • 9
  • Problem
  • Updated 3 months ago
  • (Edited)
LR Classic CC 7.0 Windows 7 w/ATI Radeon 5700
no renaming or presets, minimal previews selected
(1.8 Gb HD with 171 Gb free at the end of this import)

Preview generation/ status update tasks are not quite running in parallel with the file import??:

With an import of 887 D500 photos the library grid display shows blank grid area with "importing files" and the file counters do not change from zero for some time.

After starting the import yesterday for the first time I thought LR had crashed as there was no changes onscreen for about 5min.
However, after cancelling this import and restarting LR I found that there were photos in the destination (not showing in LR though)

Removed photos from the hard drive and started everything again this time I watched the file folder in explorer to see what was going on:

Started import @ 12:36pm
(12:45pm) After 223 photos show up in the destination directory in Windows explorer then LR grid view finally shows 8 thumbnails in the destination folder, the current import collection counter says zero & first sliver of progress appears on the status bar (this is quite late in the process to see first indication of progress)
This continues along until @ 1:14pm the destination directory had all 887 photos in it **.
LR showed only 142 thumbnails and the current import collection counter showed 30, the import process continued on until 1:35pm with all photo thumbnails finally being created.

In the destination folder there were two temporary folders created: "Temporary folder" with a HASH# and "TempParent"
TempParent contained "Temporary folder" with a HASH# folder and a 2nd copy of each of the imported photos
As the thumbnails were finally created these temporary copies were removed.
** When all of the files were copied off the card I still had 600+ extra temp folders so the import was taking almost double the space at this time.

I ran an 2nd import with 66 photos from different card reader and same process exists but thumbnail generation task keeps up better with the import so everything looks ok.
(1st card is XQD, 2nd is SDXC)
I had made several other small test imports with LR Classic to test it and everything seemed normal but this was the first large import.

Ran import with LR CC2015.12 using the same photos and the "TempParent" folder does not appear.
Just the "Temporary folder" and there is at most only one temp photo copy present in that folder while the import runs.
It took just under 4min to import and display thumbnails for 1st 225 photos, thumbnail generation was only at most 40 behind what was imported on disk.
Complete import with previews completed in 14min. So 1/4 time than LR Classic.

For some reason the temp copies/thumbnails are not keeping up in parallel to the import with larger volume imports?
Makes it look like LR crashed when there is no evidence of progress in Lightroom for 5-10min after it starts even though it is working?
And import process takes more disk space than it should.

Hopefully, I explained this ok.


Sysinfo taken after import completed:

Lightroom Classic version: 7.0 [ 1140024 ]
License: Creative Cloud
Operating system: Windows 7
Version: 6.1
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 2.6 GHz
Built-in memory: 9206.9 MB
Real memory available to Lightroom: 9206.9 MB
Real memory used by Lightroom: 3335.9 MB (36.2%)
Virtual memory used by Lightroom: 3287.4 MB
GDI objects count: 785
USER objects count: 2245
Process handles count: 3425
Memory cache size: 243.0MB
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2
Camera Raw virtual memory: 231MB / 4603MB (5%)
Camera Raw real memory: 231MB / 9206MB (2%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1200, 2) 1680x1050
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
OpenGL: AMD Radeon HD 5700 Series
Check OpenGL support: Passed
Vendor: ATI Technologies Inc.
Version: 3.3.13417 Core Profile Context 15.301.1901.0
Renderer: AMD Radeon HD 5700 Series
LanguageVersion: 4.40
Total Video Memory: 1011 MB

Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic CC
Library Path: C:\Lightroom Catalog\LR7\LR7 Master.lrcat
Settings Folder: C:\Users\Bruce\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) Facebook
2) Flickr
3) HDR Efex Pro 2
4) jf Zenfolio
5) Nikon Tether Plugin
6) ON1 Effects 10
7) ON1 Enhance 10
8) ON1 Photo 10
9) ON1 Photo RAW 2017
10) ON1 Portrait 10
11) ON1 Resize 10
12) ON1 Resize 2017

Config.lua flags:
AgView.disableDirect2D = true

Adapter #1: Vendor : 1002
    Device : 68b8
    Subsystem : 25431002
    Revision : 0
    Video Memory : 1010
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Speakers (Realtek High Definition Audio)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: 10.0x7
Direct2DEnabled: false
GL_RENDERER: AMD Radeon HD 5700 Series
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 4.5.13417 Compatibility Profile Context 15.301.1901.0
GPUDeviceEnabled: false
OGLEnabled: true
GL_EXTENSIONS: GL_AMDX_debug_output GL_AMDX_vertex_shader_tessellator GL_AMD_conservative_depth GL_AMD_debug_output GL_AMD_depth_clamp_separate GL_AMD_draw_buffers_blend GL_AMD_multi_draw_indirect GL_AMD_name_gen_delete GL_AMD_performance_monitor GL_AMD_pinned_memory GL_AMD_query_buffer_object GL_AMD_sample_positions GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_stencil_export GL_AMD_shader_trace GL_AMD_texture_cube_map_array GL_AMD_texture_texture4 GL_AMD_transform_feedback3_lines_triangles GL_AMD_vertex_shader_layer GL_AMD_vertex_shader_tessellator GL_AMD_vertex_shader_viewport_index GL_ARB_ES2_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compatibility GL_ARB_compressed_texture_pixel_storage GL_ARB_compute_shader GL_ARB_conditional_render_inverted GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_indirect GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_stencil_export GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_snorm GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_query GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_buffer GL_EXT_copy_texture GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shader_image_load_store GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_bptc GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bit GL_IBM_texture_mirrored_repeat GL_KHR_context_flush_control GL_KHR_debug GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_KTX_buffer_region GL_NV_blend_square GL_NV_conditional_render GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_explicit_multisample GL_NV_float_buffer GL_NV_half_float GL_NV_primitive_restart GL_NV_texgen_reflection GL_NV_texture_barrier GL_OES_EGL_image GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_swap_control
Photo of Bruce Houstoun

Bruce Houstoun

  • 39 Posts
  • 5 Reply Likes

Posted 5 months ago

  • 9
Photo of Ronald Byram

Ronald Byram

  • 67 Posts
  • 9 Reply Likes
HEy Bruce, Thanks for the details. I too have similar issue during import. I even went and reset LR. still today trying to import 3 Raw CR2 files and the system seems out of sync. I am trying to use that imbed/side car option. will change oto normal way and see what I get.
Photo of JonathanB


  • 12 Posts
  • 4 Reply Likes
This definitely seems to be an issue with large catalogues that have been converted to Classic.

I have tested this exhaustively in such a way as to rule out all variables relating to hardware and preference settings etc. So the new Classic import system works as advertised and is super speedy on my laptop and my desktop with a small catalogue.  The previews start populating the grid view as soon as import is started and is particularly fast with the 'use embedded previews checked’. So I know exactly how this behaves when it works properly.

However on my large main catalogue, which has 177,000 images, the previews do not start populating the grid when import is started. Instead my experience is very similar to Bruce’s.The progress bar says two operations are in progress but moves painfully slowly and there is a long wait while the grid view is empty, nothing appears to be happening and the import count remains at zero. Eventually a few previews start appearing and then a while later they all appear at once. The intended behaviour is for the previews to appear in batches so you can start viewing them immediately but instead the grid view is empty and one can do nothing but wait with the result that the overall import  experience is much much slower than 2015.12.

NB Because of the tests I have done it is clear that the problem is to do with the large catalogue and not the hardware, operating system or any preference settings  as both the laptop and desktop work fine with small catalogues (with identical preference settings) and both the laptop and desktop exhibit this major slowdown using the same large catalogue.

There are a number of similar threads in this and other forums. I hope Adobe take note and acknowledge that this is a serious flaw that needs addressing urgently. 
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 25 Posts
  • 6 Reply Likes
Hi Jonathan B,

We will look into the issue. In case you are experiencing import issues while generating previews in parallel then there is an option to disable parallel previews generation from Preferences option.

Go to Preferences> Performance.
Uncheck "Generate Previews in Parallel" checkbox

Could you please give it a try and let us know in case you still face this issue? 
We will further investigate the issue. 

Photo of Bruce Houstoun

Bruce Houstoun

  • 35 Posts
  • 4 Reply Likes
Little to no difference with the 'Generate previews in parallel' checked or not.
Also cleared Camera Raw and Video caches and renamed the Catalog previews.lrdata folder to see if that would help. Again no significant change.
Each time the previews do not show up in LR until all photos are copied off the XQD card and the temp copies take up additional disk space until they clear (so I need nearly double space that the card holds to perform an import) Also repeated this with SD card reader so not a problem with the reader.  Only using a new/very small catalog helps.
Photo of Kate Marchio

Kate Marchio

  • 4 Posts
  • 0 Reply Likes
Has Adobe explained or fixed this issue yet? This is creating massive problems for workflow and importing speed. I've been using Lightroom for years, ever since this latest update of the Lightroom 2018 CC, importing photos has become painfully slow. I have not changed anything about my workflow, hardrives, settings, etc. It used to take 10 mins to import a 32GB card, now it takes over an hour or more for only around 60 photos... trying to import hundreds takes multiple hours. Is anyone else having this issue? I have not changed any settings for import. Please help Adobe.
Photo of Bruce Houstoun

Bruce Houstoun

  • 39 Posts
  • 5 Reply Likes
After reading JonathanB's post I tested the times for my desktop with a new catalog and my converted master catalog on my laptop. Results are the same as JonathanB, the very large catalog converted from LRCC2015.12-> LR Classic catalogs perform much slower than new catalogs on the same computer.

LR converted Catalog (438000 photos) - 59 min
new test catalog (172 photos) - 18 min
(time using master catalog on LR CC2015.12 is 14min)

LR converted catalog (438000 photos)- 21 min
New Catalog (0 photos)- 4 min

(Laptop times are faster as there is a faster usb3 port for the xQD card reader, all times are for 887 D500 photos from same XQD card reader to same local C: drive as the catalog)

On the small/new catalogs previews show up right away,  initially temp folders exist for every photo but it seems there are only about 20-30 photos present at a time within them and they clear out faster.

On the converted catalogs the previews show up generally only after all files finish copying to destination folder (sometimes 6-20 show up earlier) then temp folder copies disappear as previews are generated.
Temp folders hold many more photos ~90-95% of the entire import until the last photo gets copied over before being cleared. So the import requires nearly double disk space while it runs.
Photo of Bruce Houstoun

Bruce Houstoun

  • 39 Posts
  • 5 Reply Likes
Well, I tried the imports again on a 3rd computer by installing a fresh copy of the LR Classic trial on a computer at work.

When I ran the import of 200 Nikon D500 raw files with the initial install/default catalog this import took about 3min.
Then, I repeated the same import this time using a copy of my master catalog from home (with no previews), this time the import took just under 7min. (so about twice the time)

With the 1st import as it ran the previews started showing up immediately in the "previous import" collection as the photos were copied to the destination folder. The temp folder count while initially was 200, they quickly disappeared as previews were generating. When the last photo was finished being copied, the temp folder cleanup was only a few photos behind.

On the 2nd import the import matched the same slow behaviour I have on my 2 computers at home while using the large catalog:
No previews show in the "Previous import" collection, however the counter does show some small incremental increase.
After all photos were copied to the destination folder at this point the process was just a bit behind the time for the complete import process with the other catalog, but the temp folder count is substantially behind (156 temp folders remaining) It continues to process with it only generating previews/cleaning up the temp folders.
Once all the temp folders are cleaned up then the previews show onscreen all at once.

On my other tests if there are 300+ photos being imported then preview display in the Previous import collection does catch-up a bit to at least show there is something going on but only after 5-6min of seeing nothing.
(I did not click mouse on any collections etc. for either test/ hands off keyboard too)

So, whatever the issue I have is it seems to be tied to the catalog file vs. any other config/preferences? (3 separate installs of LR now all show same problem using same catalog)

Are there any other suggestions/steps that I may try?
Adobe support: I can provide a copy of the problem catalog file via Google drive if you send me a PM.

Photo of JonathanB


  • 12 Posts
  • 4 Reply Likes
Thank you Mayuri for looking into this and thanks Bruce for your extra info.

For added detail on my set up:
Desktop:  Mac Pro (mid2010) 16GB Memory Mac Sierra 10.12.3, ATI Radeon HD5770 1024MB with1TB internal SSD
Laptop: MacBook Pro Retina (Early 2013), 2.7 Ghz Intel i7, 16GB Memory, Mac sierra 10.12.3, Intel Graphics 4000 1536 MB with 500GB internal SSD

Lightroom Classic 7.0.1 is installed on both machines. Main Lightroom catalogue folder is stored on External SSD, Original files stored on USB3 External 7200 RPM Drives
My original comments were therefore based on testing the identical large catalogue powered by Desktop or Laptop (connected to same external drive) as well as various permutations of new/small catalogues on the separate machines.

I have now done a new test on the same large catalogue with the ‘Previews in parallel’ option checked and unchecked. Import options set to Embedded and Sidecar.
It is slightly faster with ‘Previews in Parallel' checked (enabled)
I have only tried this on the Desktop. For the purposes of this test files were set to import into a folder on the Internal SSD.

1. Timeframe of onscreen information when importing 50 images (2GB) using USB3 Card Reader - 'Previews in Parallel’ UNCHECKED

0-10 seconds -  ‘Copy and Import’,  Current Import Count reads 0, Grid view says ‘Importing files’, No previews showing.
at 10 seconds - '2 operations in progress’, Current Import Count 0, Grid view says ‘Importing files’, No previews showing.
at 31 secs  -'2 operations in progress’, Current Import Count 1, Grid view says ‘Importing files’, No previews showing.
at 39 seconds - ‘Copy and Import’, Current Import Count 1', Grid view says ‘Importing files’, No previews showing.
at 1min 20 - ‘2 Operations in progress’, Current Import Count 4' , Grid view says ‘Importing files’, No previews showing.
at 2min 10sec - '2 Operations in progress’, Current Import Count 16', Grid view FIRST PREVIEWS APPEAR.
at 2min 15sec - ‘Fetching Initial Previews'
at 2 min 47 process complete.

2. Identical import of same images with same set up except ‘Previews in Parallel’ CHECKED
First 3 previews appear in grid after 50 seconds followed by all the rest at 1 min 50secs
Whole process completes 2 min 11 secs.

I have taken videos if you would like me to send these to you.

NB these tests are just with importing 50 files (2GB) - a full 32 GB card, typical for a day’s shoot, obviously takes much much longer! No previews appear in the Grid view for many minutes then all arrive more or less at once at the very end.
My sense is that tests results are somewhat inconsistent but I don’t have the time to test and record results exhaustively with every variable and permutation.

As previously stated on both machines, when running smaller catalogues, the Previews start loading instantly in grid view so you can start culling them - which I assume is the intended behaviour regardless of catalogue size.
Photo of Kate Marchio

Kate Marchio

  • 4 Posts
  • 0 Reply Likes
This is interesting, yet why would Lightroom make it slow for professionals that have large catalogs? My catalog sizes are going to be massive and that isnt going to change? So why would Adobe handicap the pros using their software? How can this be fixed without changing catalog size? Import speeds are painfully slow and are really creating a major issue in workflow and efficiency. Especially because up until now it worked just fine. Adobe dont take away features that are good for your users. When you compromise user experience you are compromising your key users.
Photo of JonathanB


  • 12 Posts
  • 4 Reply Likes
I’m quite sure they did not do this on purpose. According to their PR, the whole point of the recent changes was that they could now focus on making speed improvements in Classic for heavy duty users. This must be an unintended bug introduced as a result of this aspect of Lightroom code being re-written. I experimented reverting to my old method from a few years ago of transferring files from card reader to disk with Finder and then importing into Lightroom direct from the folder however even that had the same problem of previews not appearing in the grid until the end of the import process.
I believe some people are importing into smaller catalogues for urgent time-critical work and then exporting as a catalogue and transferring to their main catalogue at a later date but this seems like too much of a faff to me, so for the moment I’m just trying to be patient and setting downloads to import whilst I have something else to do.

Hopefully they will come up with a fix soon.
Photo of Sean Molin

Sean Molin

  • 7 Posts
  • 4 Reply Likes
Same problem. Abysmal import speed and previews basically don't show up.
And turning off concurrent preview generation wouldn't help, because this slow down is during the actual import before previews begin generation.
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 25 Posts
  • 6 Reply Likes
Hi Sean,
Could you please try import with minimal previews in new catalog and let us know the time taken to complete import operation in LR classic?
Please also mention the no. and type of images you are trying to import.

Photo of JonathanB


  • 12 Posts
  • 4 Reply Likes
Hi Mayuri,
I forgot to mention that when testing (as per my post above) I also experimented with using the minimal or standard preview generation settings (as well as embedded and sidecar). It made no difference to the behaviour in the larger catalogue (previews only start appearing in Grid view towards the end of the process) whereas as all options work perfectly in new or small catalogues on both laptop and desktop (with previews appearing instantly). Happy to send videos if you want.
Photo of Philippe Coudé du Foresto

Philippe Coudé du Foresto

  • 18 Posts
  • 4 Reply Likes
I too experienced the same problem with LR Classic 7.0.1
Photo of Terri Glanger

Terri Glanger

  • 8 Posts
  • 1 Reply Like
Same problem - cannot believe there is no fix to this yet.  My import time is excruciating and only a few photos show up (like 3) until the import is finished.  I'm a commercial photographer and this is really problematic.  I hope there is a bug fix to this SOON.  
Photo of Chris Hitchcock

Chris Hitchcock

  • 8 Posts
  • 1 Reply Like
I've resorted to sorting and culling in Perfect Browse, then importing only my urgent edits into Lightroom. The rest get done overnight. It's a pretty pathetic situation for such a major software vendor to have created.
Photo of Kate Marchio

Kate Marchio

  • 4 Posts
  • 0 Reply Likes
Now I just updated again and it wont fully import my card, I only have around 50 photos to import and a few short videos and it gets around 95% of the way across the bar and then it just never completes, I let it fun for several hours it wont import the card fully.  This needs to be fixed immediately Adobe!
Photo of Bruce Houstoun

Bruce Houstoun

  • 39 Posts
  • 5 Reply Likes
I see that Adobe has replied in another thread that they were able to replicate this issue with large catalogs and slow imports.

Now to sit back and wait for Classic 7.1 for the fix.
Photo of Phil Jack

Phil Jack

  • 2 Posts
  • 0 Reply Likes
Lightroom Classic CC slow to create 1:1 Previews during import?

It's a massive bug in 7.0.1! Roll back to 7.0.0 and you'll be back to normal.

Launch the Adobe Creative Cloud app.
On the Apps tab, click on the drop down arrow next to Lightroom Classic CC and choose Other Versions.
Choose 7.0 and click Install
Be amazed that Adobe could screw up Lightroom so badly but revel in the fact that you are working again.
Photo of Grant Gunderson

Grant Gunderson

  • 1 Post
  • 0 Reply Likes
I too am having the same problem on a 2017 MacBook Pro. Library is 483K. Just tried to import 50 images and its taking over an hour and thats a full SSD machine storing to only SSD drives.  Did Adobe even test this update before releasing it?
Photo of Bruce Houstoun

Bruce Houstoun

  • 39 Posts
  • 5 Reply Likes
Some improvement for importing with LR7.1:
Importing of same 887 photos now took 36 min vs previous 59min and some previews started showing onscreen immediately but still not as fast a new catalog or using LR2015.12
Will repeat tests with clean catalog and on laptop tomorrow.
Photo of Reetesh Mukul

Reetesh Mukul, Employee

  • 15 Posts
  • 0 Reply Likes
I have few questions:
  1. How much time Import was taking on LR2015.12 vs LR7.1 ?   This is just Import completion time.
  2. How much time Preview took  on LR2015.12 vs LR7.1 ?
  3. Are you using Windows or Mac ? SdCard or Non-SdCard ? If you are using SdCard and MAC can you try Import with Folder Tree instead of Devices option.
  4. Please calculate above with Import + Minimal
Photo of Bruce Houstoun

Bruce Houstoun

  • 39 Posts
  • 5 Reply Likes
Using LR on Windows 7
Test with Master catalogs that have 435000+ photos and a very small LR7 test catalog with only 172 photos in it prior to the tests. Importing 887 D500 photos using Lexar XQD card reader

LR7.1  (master catalog) - 36min
LR7.1 (small catalog)  -21 min

Lr2015.12 (master catalog) - 15min

** Update as I decided to record the time for a direct Windows file copy followed by use LR import from harddrive using add mode I saw that I had TeraCopy running as my default file handler.
Disabled TeraCopy and ran the Windows file copy/LR Add - 15.5min

Re-ran LR7.1 import with TeraCopy disabled and import was now down to 20min.
So not as fast as LR2015 but disabling TeraCopy made quite a improvement.

Will test LR7.1 tomorrow with my laptop (which does not have Teracopy) to see how it performs there. Old LR CC2105 was not affected by TeraCopy to the same extent it seems as for LR7.x

So for the most part it seems to be working better, except the creation of the files in the temp folder still accumulate causing the import to use more disk space while running. There is about 1.5-1.75 times the total disk space used temporarily as compared to the imported file size total.
Photo of Reetesh Mukul

Reetesh Mukul, Employee

  • 15 Posts
  • 0 Reply Likes
I will wait for results on your laptop. What is Storage technology for your this Windows 7 System ? Is it HDD based on SSD based?
Photo of William Carey

William Carey

  • 1 Post
  • 0 Reply Likes
Can someone tell me if Adobe have answered this upload speed problem anywhere. Unbelievably slow uploading 300 images. Though problem was my laptop until I found this thread!
Photo of Rebecca Douglas

Rebecca Douglas

  • 1 Post
  • 0 Reply Likes
Is there a solution to this yet? I am sat backing up in the middle of a wedding, while everyone eats and so far in over an hour 27 RAWs have imported. I would normally have had everything I'd shot from morning prep - sit down meal imported and backed up by this point. Working on macbook with no power supply and I am down to 65% battery so there is no way I am going to be backed up before I need to shoot again and before the battery runs out. This will massively effect the service of same day previews that I offer! HEEEEEELP!!!!!
Photo of Todd Shaner

Todd Shaner, Champion

  • 633 Posts
  • 178 Reply Likes
Try using Finder to transfer the remaining files directly to the target HDD folder. Once completed right-click on the folder inside LR and select Synchronize folder. See if that speeds up the process.