LR Classic on Mac - CRASHES CONSTANTLY

  • 5
  • Problem
  • Updated 7 months ago
Running iMac (Late 2012) with Sierra Version 10.12.6

Updated to the new Classic LR and now LR crashes every few minutes - it doesn't seem to matter what I am doing, one time I changed a White Balance, other times I was making different adjustments.

of course I can't go back to the old version as my catalog was upgraded.

This is service affecting, and needs to be fix immediately.  
Photo of Doug P

Doug P

  • 5 Posts
  • 4 Reply Likes
  • mad and frustrated

Posted 7 months ago

  • 5
Photo of ragrawal

ragrawal, Employee

  • 11 Posts
  • 1 Reply Like
Hi Doug,

Can you please submit the crash reports.

Regards,
R. Agrawal
Photo of Doug P

Doug P

  • 5 Posts
  • 4 Reply Likes
I have submitted crash report after crash report - the program crashes every couple minutes if i try to do anything.  it will run forever if i don't touch it.  How do i revert to the old version and get rid of this piece of fucking crap
Photo of Carlos Cardona

Carlos Cardona

  • 238 Posts
  • 42 Reply Likes
This isn't likely a LR Classic problem, but a Mac issue. I have a late 2015 iMac, same OS, no issues. Please give your computer the "once over"? Run Onyx (https://www.titanium-software.fr/en/onyx.html), reboot. Run Disk Warrior (https://www.alsoft.com), reboot. Or first try it from your other (admin) account, as a test. Crashes? If it doesn't crash it's a corrupted preference in your Library. Check The Lightroom Queen site for instructions on how to reset your preferences.

PS-After a LR crash you should reboot (yeah, forget Apple's advice about not having to reboot, that doesn't apply to BIG apps!)
(Edited)
Photo of Doug P

Doug P

  • 5 Posts
  • 4 Reply Likes
it is NOT my computer - this started the minute i upgraded to the new version 
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1385 Posts
  • 413 Reply Likes
Try turning off the GPU acceleration from the Lightroom preferences dialog to see if it helps. For details see https://helpx.adobe.com/lightroom/kb/lightroom-gpu-faq.html .
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1385 Posts
  • 413 Reply Likes
If the crash disappears after turning off GPU acceleration, try tip #2 described here (work for mac as well) https://helpx.adobe.com/lightroom/kb/crash-gpu-directx-enabled.html and try to turn the GPU acceleration back on again and see what happens.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1385 Posts
  • 413 Reply Likes
Hi Doug, 


When you submit the crash report, please enter your email address in the Adobe Crash Report dialog before pressing the Send button. I searched the report using your email address and found no hits.

Could you post Lightroom's system info (Lightroom>Help>System Info...) here?

Have you tried the steps that I suggested above? The other thing that you could do is resetting the Lr prefs (pressing Shift+Option when launching Lr Classic CC).