Lightroom Classic: Noise reduction effect not displayed in Develop mode

  • 22
  • Problem
  • Updated 9 months ago
  • In Progress
  • (Edited)
Noise reduction effect not displayed in Develop mode when image is smaller than 1:1. Enlarged is ok, but when I set FIT or FILL, image displayed without noise reduction settings applied (I think so).
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes

Posted 1 year ago

  • 22
Photo of Kimberly Chan

Kimberly Chan

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom CC Classic: Images are grainy in Develop Module.

Along with other problems in the new LR Classic, my images are grainy in Develop but not in Library or during export. The develop module overall has been extremely slow to respond to sliders. 

I run MacOS El Capitan with 32GB RAM. 

Anyone know how to fix this issue? Thank you in advance!
Photo of Gabriele Rinelli

Gabriele Rinelli

  • 4 Posts
  • 1 Reply Like
turn off graphic processor
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
Spoke to the tech support guy today. They said my GPU doesnt support LRCCC. I think its ludicrous that a GTX Titan doesnt support LRCCC. Weighing up option elsewhere, Capture ONE, DXO and ON1. Hopefully Adobe will have a solution or a better answer by the end of the year. At this point Rawtherapee is better than LRCCC. It doesnt support GPUs....but its free and I know what I'm getting.
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
Its garbage, reading this thread alone people are using many different GPUs ranging from 1-2 years old to released a few months ago and have the same issue.
The odds on all these cards (which dont forget ALL previously worked on lightroom) suddenly not supporting it are remote.  Its most likely that LRCC doesnt support THEM.  Which given it used to means its a bug.

If that is the official support response im very disappointed as they clearly haven't read this thread or collated any information at all and seem to be content to ignore the problem.  What we have here is a repeatable with 100% accuracy issue affecting a large variety of video hardware on many different drivers and rarely for bugs, exhibits on both PC and Apple.  All of those hint to a code issue.

Capture 1 is looking more and more tempting albeit its more expensive.  The main thing holding me back is the nightmare of converting, changing over and learning a new work flow.  That and i still need PS for some tasks so its an additional cost per month rather than a replacement.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4426 Posts
  • 1637 Reply Likes
I wouldn't set too much store by what the phone/chat support say. They have been known to get stuff wrong. There's a few people with different cards suffering the same issue, and engineers busy on the thread looking into it, so I'd wait and see what they say.
Photo of Rudi

Rudi

  • 10 Posts
  • 1 Reply Like
The noise issue remains the same. It doesn't matter if you enable or disable GPU! And it remains the same that as soon as you move a slider the process version changes automatically to version 4. That classic release is just garbage. Sorry to say that.... oh yes, and in process version 2 the noise issue is not there....
(Edited)
Photo of Gabriele Rinelli

Gabriele Rinelli

  • 4 Posts
  • 1 Reply Like
Same problem solved turning off the graphic processor AMD Radeon HD 7900 Series latest driver
Photo of John R. Ellis

John R. Ellis, Champion

  • 3857 Posts
  • 1014 Reply Likes
Another person with possibly similar symptoms: https://feedback.photoshop.com/photoshop_family/topics/bug-report-what-is-that-develop-module-not-tr...

To other moderators: Note that Todd's report and that other report, both concerned with Library, are different from the rest of the reports here, which are concerned with Develop.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1109 Posts
  • 358 Reply Likes
I am seeing an issue with noise reduction not being applied in the Library module when using any of the pyramid Zoom View settings except 1:1 and 1:2 with LR Classic on Windows 7 and Nvidia Quadro 600 graphics card.

The issue is observed when 'Use Graphics Processor' is unchecked or checked in Preferences. To duplicate what I'm seeing select a high ISO raw image with noise. Apply Sharpening Amount 100, Luminance 25 and Color 25 Noise Reduction. Next select 1:3 Zoom View and switch between the Develop module and Library module. It could take up to 15 sec. for the Library image to appear without noise reduction, but it will every time on my system! I'm guessing this is a Direct X vs Open GL rendering issue.

Update: The same issue can be observed using a JPEG export file of the above raw image file. Since no settings are applied to the JPEG this is strictly a display path rendering issue. I confirmed that LR CC 2015.12 does NOT exhibit this issue.

(Edited)
Photo of John R. Ellis

John R. Ellis, Champion

  • 3857 Posts
  • 1014 Reply Likes
Merging with another topic.

Please reference the new conversation here: Noise reduction not being applied in Library module
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
There was an LR update....which didn't really address any of the issues...for me at least. I wonder if the LR people actually see this....cos its a photoshop feedback thingy.

According to the update webpage, if it don't work use LR 6....which pissed me off :)
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
7.01 doesn't appear to have done anything for this bug.  Still present
Photo of Edgar Batista

Edgar Batista

  • 5 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled The develop module shows a lot of grain when the gpu processor is active.

When I enter the develop module, the image starts to appear dim and with lots of noise, but after a few seconds, everything is "normal".
However, since the last update, the image never gets "normal" unless I disable the GPU. This had not happened before (last version).
This may be more or less noticeable, depending on the image, but in all of them, a grain increase occurs when the GPU is active.
I have already confirmed and my drivers are up to date.
I am using a GeForce GTX 960M (notebook) and RAW files are from a Canon 6D Mark II
Photo of Assaf Frank

Assaf Frank

  • 148 Posts
  • 46 Reply Likes
if I use smart previews it is ok (noise reduction is applied to the preview) if I use no smart previews then the problem exists. W10 GTX 980Ti latest nvidia drivers from 30/10/2017. in 1:1 noise reduction is ok at all times.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Preview rendering post-batch edit.

I'm having a very unusual problem with preview rendering in LR classic on Win 10. I'm working on a timelapse and edited one photo in the series. I then synced the edit to the rest of the ~300 photos. The sync was completed, but the previews were then rendered as very pixelated. The only way I can get them to render properly is to click on each photo one-by-one in the develop module and wait for a couple seconds, or build 1:1 previews. I have tried disabling GPU and restarting LR, as well as restarting my computer. I have left LR idle for a while, and my CPU is idle, so nothing is happening in the background. The pixelated images do get incorporated into my timelapse, when using a timelapse preset I downloaded and added into the slideshow module. However when I export individual photos they look fine. Here is an example of before and after building a 1:1 preview. Look at the sky to see what I'm talking about.
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 178 Posts
  • 51 Reply Likes
Every time you do any edit on an image, all of the previews are invalidated, which is why it usually doesn't make sense to generate 1:1 previews as in many cases they will get invalidated anyway very quickly. 1:1 previews only make sense for very high volume shooters that as their first step select only those images that are correctly in focus.

For this case, check what is set for your standard preview size. Make sure it is big enough for your display. Usually the Auto setting works well. This is done in Catalog Settings -> File handling. It usually takes a few seconds to generate new previews after any change to the Develop settings and in the intervening time the preview in Library will look pixelated.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Thanks, I'm an experienced user and understand 1:1 previews. I usually don't bother to pre-render them. My standard previews are set to auto.

Rendering is happening just fine in the develop module, but fails in the library module. When I batch edited my photos, only the ones that I subsequently clicked individually in develop looked ok in library.  All the rest were heavily pixelated in the library, and remained so until I forced a build of 1:1 previews for all the photos. This is definitely a new bug that is unrelated to noise reduction. My post should not have been merged into this noise reduction thread.
Photo of kitty van gemert

kitty van gemert

  • 19 Posts
  • 2 Reply Likes
This reply was created from a merged topic originally titled LR Classic library previews not updating after develop edits.

In library module the preview of an image is not updated after returning from developing module. The only way to get it to update from pixelated/lined view is by either rebuilding the 1:1 preview (i built those on import already) or by zooming in. So i have to 'force' LR to do this by performing an action. Waiting for it to happen without doing anything is not working.
I developed an image with a (very) blue sky in develop module. If i go back to that image it takes a bit for the blue sky to 'smooth out' it looks lined and pixelated at first.

Mac 10.11.6
LR Classic 7.0
32gb ram/i7
for now gpu unticked because of the noise reduction bug (NVIDIA GeForce GTX 780M 4096 MB)
Photo of Alan Harper

Alan Harper

  • 430 Posts
  • 85 Reply Likes
I very much wonder if the various merged threads are the same issue, but in response to one of them:

My edits in Photoshop are often not visible after I return to Lightroom. I haven't figured out any rhyme or reason to this. The Photoshop files are large (1-3 GB), but with Lightroom CC 2015 they updated soon after Photoshop was done writing the file. Now, not always.

I haven't figured out how to trigger an update — rebuilding previews seems to do nothing, as Lightroom seems to believe that preview is up to date, and I can't convince it otherwise. Even "touching" the file (changing the file modify date) does not seem to help. Then, sometimes after few minutes, the preview will update in Lightroom.

Lightroom CC Classic 7.0.1 + Mac OS Sierra 10.12.6.
Photo of Peter Dinh

Peter Dinh

  • 1 Post
  • 1 Reply Like
I can also confirm this is happening to my system as well after updating to Classic. I see grainy/noise in FIT view, and turning off using GPU resolved the issue, but this is unacceptable to me. Hopefully there will be a fix for this from Adobe, there's way to many different variables and system configurations in this thread for it to be graphics card issue/driver.
Photo of Declan Lee

Declan Lee

  • 3 Posts
  • 0 Reply Likes
Any updates on this issue? It's really starting to get under my skin, it's having a massive impact on slowing down my workflow by having to have GPU acceleration off
Photo of darren hamlin

darren hamlin

  • 1 Post
  • 1 Reply Like
This reply was created from a merged topic originally titled Lightroom Classic CC Develop module Noise Problem.

When viewing an image in Develop Module it does not show any noise reduction you have done, in fact it seems to add noise. If viewed in library, then it shows, it’s correct, as does the export. In 1:1 you also see the noise reduction. Also, if viewing in Develop Module and you move a slider, for a split second it shows the correct image with noise reduction.

If you turn off the GPU then it acts as it should. I had a chat with Adobe and he saw the problem, but was at a loss. Then he said it was a driver issue. I am running a 5k 2017 iMac with Radeon 575, and also replicated the problem on two MacBook Pros. I called Apple, and they confirmed all drivers are up to date. The Adobe guy disappeared.

I am convinced this is an Adobe issue, as up until the updates a couple of weeks ago everything was smooth.

Just need clarification from Adobe that they are aware of the problem, but I have seen other users on other forums with the same issue, and the same response from Adobe support.

When editing higher ISO images with night skies or blacks it is critical to see the image as is in Develop Module.
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
I also think Adobe people should officialy aknowledge this problem, and tell us if they're actually working on int. I can confirm everything you said in your post.
Photo of Luke Dyson

Luke Dyson

  • 11 Posts
  • 6 Reply Likes
It’s so frustrating, updates to the new cloud version went out yesterday but not to classic. Sign of things to come I guess...
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4426 Posts
  • 1637 Reply Likes
Luke, don't worry, that was just a minor double-dot release to fix a crash bug. Classic actually got the same fix a couple of weeks earlier than CC.
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
So, anybody knows if Adobe is working on a solution? Is obviously not a driver problem, not a certaing gpu problem, I'm using a gtx 1060 and I've read people with different gpus, brands, and os systems having the issue, so it's obviously a Lightroom problem as many people have already stated. We're abandoned?
Photo of Jerry Syder

Jerry Syder

  • 224 Posts
  • 109 Reply Likes
Hey Ander, they are and I believe it would be released soon. It's nothing to do with your hardware and a confirmed bug. 
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
Thanks for your answer Jerry, and I truly hope you're right. But I'm not so confident, since a month has gone by, and still yesterday on adobe forums some kind of moderator was still telling me that might be a problem with my hardware or drivers, when obviously it's not. We'll just have to wait and see...
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
gpu driver update 388.31 - no bueno
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
It's not related to those drivers or to a certain driver update. Has happened to people on mac and on windows, and with very different gpus (radeon, gtx, etc.). There's people who has even tried installing 4 different drivers and still no luck.
Photo of Paweł Guraj

Paweł Guraj

  • 3 Posts
  • 1 Reply Like
I have exactly the same problem on MacBook Pro (mid 2017) with Radeon Pro 560 (High Sierra 10.13.1) and LR CCC (7.01).
With GPU disabled everything is ok, but with GPU enabled noise reduction is not visible in Develop module FIT view (only visible in 1:1) and also very often previews are not updated in Library module when exiting from Develop module.

Everything worked perfectly ok on the same hardware with LR CC 6.x

br, pawel
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
I also have the problem with previews not being updated in the library module. The only solution I have found is to force a build of 1:1 previews. I'm certain this is a separate issue than the noise reduction bug. I've reported this as a different bug. It got merged into to this thread by the admins but I've reposted it. It would be helpful if you could add a a comment to the thread.
https://feedback.photoshop.com/photos...
(Edited)
Photo of Luke Dyson

Luke Dyson

  • 11 Posts
  • 6 Reply Likes
So they confirm they’re working on it but no specifics on when... https://twitter.com/lukedyson/status/...
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
Thanks for the info Luke, we'll see if this is a priority for them or not...
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1488 Posts
  • 470 Reply Likes
A fix for this issue has been made for the next scheduled Lightroom update.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
That's great news. Thanks for the update. What about the problem with previews not rendering properly in the library module?
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1488 Posts
  • 470 Reply Likes
>What about the problem with previews not rendering properly in the library module?
Could you help pointing to the thread that report the issue? Just want to be sure which one you are referring to?
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Here is a post on this bug. Kitty and I discovered it together. It happens consistently. If I make an edit in develop and then switch over to library, the preview doesn't render properly in library. Solid blue color in particular appears very pixelated. It only renders correctly if you force a rebuild of 1:1 the preview.
https://feedback.photoshop.com/photoshop_family/topics/lightroom-classic-library-preview-not-showing...
Photo of Paweł Guraj

Paweł Guraj

  • 3 Posts
  • 1 Reply Like
Yep, exactly. It happens almost every time (completely pixelated nad banded sky). In my case independent of GPU enabled or not.
Zooming into 1:1 waiting till "loading...." disappears and zooming out solves problem for currently viewed picture.

br,pawel
Photo of Todd Shaner

Todd Shaner, Champion

  • 1109 Posts
  • 358 Reply Likes
Simon will this also fix the issue with noise reduction not being applied in the Library module when using any of the pyramid Zoom View settings except 1:1 and 1:2?

https://console.getsatisfaction.com/photoshop_family/conversations/lr-classic-noise-reduction-effect...
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Pawel, same for me, it's also independent of whether I have the GPU checked. 
Photo of Алексей Иванов

Алексей Иванов

  • 2 Posts
  • 2 Reply Likes
I have the same issue with new GeForce 1030 2Gb card. As other users I can see temporarly applyed Noise Reduction when qucickly dragging sliders in Basic. When I move sliders not only NR looks applyed, but the colors of image look tinted to red a little. It's clearly visible when disabling Luminance and Color Noise Reduction. When Use graphics processor is unchecked, evereything is OK.
Photo of Robert Frost

Robert Frost

  • 396 Posts
  • 53 Reply Likes

If unchecking 'Use Graphics Card' solves your problems, why do you want to check it? It is only designed for 4/5K monitors to make them respond a bit faster. Doesn't do anything for smaller monitors. Many graphics cards and drivers don't seem to be compatible with it.

Bob Frost

(Edited)
Photo of Paweł Guraj

Paweł Guraj

  • 3 Posts
  • 1 Reply Like
But I'm using 4K monitor and Retina display (which is in every MacBook since some years). And with GPU acceleration disabled LR CCC is absolutely f... slow. No way to normal work. Any zoom or pan of processed photo takes ages to complete.

Besides You don't have any drivers on Mac - this platform is really standardized, so no way to excuse for Adobe that something is not compatible.

br,pawel.
Photo of Алексей Иванов

Алексей Иванов

  • 2 Posts
  • 2 Reply Likes
Perfomance is very good with graphics processor enabled on my old 1680x1050 monitor. I see very huge difference in speed when GPU is disabled in new Lightroom CC Classic.
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
When is this update happening? Its an important update to people with this issue. We need to get it as soon to make lightroom usable
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 335 Reply Likes
Timing of updates isn't normally announced until the day of the update.  Any question beginning with the word "When" will likely go unanswered. 
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
So I have to indefinitely wait/make payments for a solution that may or may not work? :D
Photo of Gary Rowe

Gary Rowe

  • 97 Posts
  • 34 Reply Likes
Its almost like businesses want to know how long problems will last so they can plan accordingly ...
Photo of Adam Kupka

Adam Kupka

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Display bug when "Use Graphics Processor" is selected.

When "Use Graphics Processor" is selected (Preferences > Performance), all images in the develop module appear very grainy as if shot at an extremely high ISO, regardless of original image or sharpen settings. This grain is not present when exporting the final image, or opening in any other program (including Photoshop).  When the box is de-selected, the grain disappears and the images displays as it should. 

Windows 10
Lightroom Classic 2018
NVidia Quadro M2000M
Photo of David Savill

David Savill

  • 1 Post
  • 0 Reply Likes
It's doing this on my iMac, using Lightroom Classic CC

I'm trying to edit some photos I've taken inside a Royal home today and, I cannot see the damn noise reduction effect with the Luminance slider, it's making it very difficult to work with certain images.

What the hell is going on?

It'll work on Fill now but not Fit. This looks like a bug, which Adobe has no excuse for.
Photo of Stephanie La Forge

Stephanie La Forge

  • 1 Post
  • 0 Reply Likes
This fixed it for us too:  "I've disabled the "Use GPU" in the menu and restarted lightroom.  Without using GPU acceleration normal behaviour is restored, it renders NR and Sharpening in fit and fill views.  Re-enabling GPU functions and it stops again."

It drove us nuts for like 4 hours, trying to fix it. You saved our sanity. 
Photo of Luke Dyson

Luke Dyson

  • 11 Posts
  • 6 Reply Likes
Does today's update fix this? I'm hesitant to install any further update
Photo of Jerry Syder

Jerry Syder

  • 224 Posts
  • 109 Reply Likes
It does Luke. 
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes
I confirm. After last update, the image in old LR CC and new LR Classic are the same. NR is displayed in 'fit' and 'fill' and '1:1'. GPU enabled.
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
Yep, me too I can confirm, glad they fixed it, not a driver problem after all as we have been repeting.