Lightroom Classic: Noise reduction effect not displayed in Develop mode

  • 22
  • Problem
  • Updated 5 months ago
  • In Progress
  • (Edited)
Noise reduction effect not displayed in Develop mode when image is smaller than 1:1. Enlarged is ok, but when I set FIT or FILL, image displayed without noise reduction settings applied (I think so).
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes

Posted 9 months ago

  • 22
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes
In addition. When press before/after button and copy 'after' settings to 'before' - 'before' image displayed with noise reduction, 'after' image without.
Photo of Russell Cardwell

Russell Cardwell

  • 39 Posts
  • 17 Reply Likes
That's not new. LR doesn't display noise reduction or sharpening results except at 1:1 or above. They're still there, and will export correctly. But they aren't rendered at less than 1:1. After they are exported they are "baked in" and visible at any size.
Photo of eartho

eartho

  • 799 Posts
  • 194 Reply Likes
It's always been that way. There's even a little ! mark in the Detail tab which explains the issue...
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
No.
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
I think this is a new issue with LRCCC I have this same issue. All my old files(pre LRCCC) show noise reduction at "fit". Any new file i import doesn't show noise reduction in develop module.
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes
I found a sign '!' with an explanation, but it worked well in LRCC before upgrade to Classic without zoom to 1:1. Is there a way to configure Classic do same?
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
UPDATE: If i have noise reduction at 100%, with the size set to "fit" and White Balance at "auto" the noise reduction effect shows up in "fit" size.

Basically it seems to be linked with the white balance.
If WB is "auto" NR shows in "fit".
If WB is anything other than "auto" NR doesnt show in "fit"

Looks like a glitch to me...or maybe noise reduction is linked with camera WB. Anyone else seeing this?

Also, all my already edited files show NR at "fit"
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
Same problem here, no NR is displayed at all in my standard "fit" view but is applied when i zoom in.  Unlike the above my white balance has no effect on this.
This is a different behaviour from LR6 and CC which did update NR on the "fit" view quite happily.
Confirmed this by running LR6 with the same catalogue and image.

Its a fairly serious bug as i really cant tell whats happening to my image when making changes if the whole thing appears with noise.
Photo of eartho

eartho

  • 799 Posts
  • 194 Reply Likes
Sorry, but no matter what you see or imagine, noise reduction is only accurate and visible at 1:1 view. What you're seeing when you fit is simply an approximation of some sort. If you need to see exactly what you're NR looks like, then either zoom 1:1 or use the preview window in the Details tab.
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
Its an approximation that is accurate, gives a good general feel of the image and something lightroom has done for years.
Photo of Jerry Syder

Jerry Syder

  • 190 Posts
  • 91 Reply Likes
@eartho Whilst this is true, as in it's advisable to better see the effect of noise reduction and sharpening at 100%, previously, you were still able to see the effect at fit or fill when NR was applied. Now, if you drag the noise reduction slider to the far right, you see absolutely no change at fit or fill. This is an incorrect behaviour of LR
Photo of Andrew Keher

Andrew Keher

  • 1 Post
  • 0 Reply Likes
Don't try and justify this change by saying we should be zooming in on every picture. We want the effect (approximation or not) that was enabled in the previous version, what possible reason do they have to remove it?
 
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
Here are some pics. Hopefully the differences are visible on the screenshots
 
Image 1: NR-0 and WB-auto


Image 2: NR-100 and WB-auto


Image 3: NR-0 and WB-As Shot


Image 4: NR-100 and WB-As Shot
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
Ive found a non ideal workaround.  I've disabled the "Use GPU" in the menu and restarted lightroom.  Without using GPU acceleration normal behaviour is restored, it renders NR and Sharpening in fit and fill views.  Re-enabling GPU functions and it stops again.
FWIW im on Windows 10 autumn update, GeForce 1060 with latest drivers.

Maybe someone else experiencing this issue can test with and without GPU acceleration and a LR restart.
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
OK im seeing the GPU thing as well. So it must be a driver compatibility issue with the new LRCCC. Im using a GTX titan
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
Id go more for LR bug than driver issue.  Ive just tried it on older drivers as well.
Performance doesn't seem and different at all with GPU acceleration turned off so for now i guess i'll have to leave it off to avoid losing this very very useful feature.
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
I was just on tech support with adobe and the guy said my GPU was outdated (LOL) he said to wait for a GPU firmware update. LRCCC requires directx 12 or Opengl 3.3. My GPU supports both
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
I updated the GPU drivers from 385 something to 387.92 but no luck
Photo of Davi Siqueira Silva

Davi Siqueira Silva

  • 3 Posts
  • 1 Reply Like
It's good to see that I'm not the only one having this bug. I have a GTX 850m and the bug disappears when I turn the GPU acceleration off. I hope Adobe adresses this issue ASAP, because I really feel a drop in performance when I'm not using hardware acceleration... And it's pretty clear that this is not a graphics card driver issue, since there was no bug when using the older versions of Lighroom.
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
The issue seems to happen with files I edit after updating to LRCCC. Meaning my older files, which I have already edited dont have this issue. Its only on files I havent edited before. Looks like a driver issue to me...or driver-lightroom compatibility issue.
Photo of Davi Siqueira Silva

Davi Siqueira Silva

  • 3 Posts
  • 1 Reply Like
I think it's probably a driver-lightroom issue... But the thing is: everything was working just fine before the update. I hope Adobe and nVidia to work together to fix this ASAP.
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes
Disabling GPU acceleration solve the problem for me (GT650m). Not sure about performance changes. My files already edited in LR6 have this issue, but think I'm did't exported they before. 
Trying to update macOS for latest version and test.
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
FWIW ive since tried 3 different drivers ranging from this months latest release to ones for March.  The issue is present on all on them in LR classic.  The issue is NOT present on old Lightroom CC/6 using any of those drivers.
So im going for a bug in LR Classic itself as opposed to a driver issue as all of them worked perfectly on older versions of lightroom.
"Old" video card is rubbish as well, people are getting this with 1050/60/70/Titan range modern high end cards - there are no newer ones!

What OS are people experiencing this on?  Im using windows 10 (autumn creators update) and it does it.  It is doing it for apple users or win7 users as well?
Photo of Declan Lee

Declan Lee

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled GPU Acceleration Bug/issue.

With new lightroom Classic CC there seems to be a problem with GPU acceleration whilst on Images are showing significant grain, almost like no noise reduction has been applied

The two images below the only difference between them is GPU acceleration on vs off. Obviously, it's a bad photo but it demonstrates the problem quite clearly 

Sorry had to upload to dropbox couldn't post a Jpg apparently 

https://www.dropbox.com/s/n4cipdmcroal1d9/Screenshot%202017-10-22%2018.01.09.png?dl=0 https://www.dropbox.com/s/qn4whgz8c7g59xy/Screenshot%202017-10-22%2018.01.28.png?dl=0 

I've updated Adobe CC and my Nvidia Drivers 
My GPU is a "Geforce GTX 980Ti" 

Any help is really appreciated 
-Declan 
Photo of Venkatesh Penjuri

Venkatesh Penjuri, Official Rep

  • 42 Posts
  • 12 Reply Likes
Hi all,  please follow the step 2 mentioned here https://helpx.adobe.com/lightroom/kb/crash-gpu-directx-enabled.html and let me know if this helps.
(Edited)
Photo of Ad Dieleman

Ad Dieleman

  • 31 Posts
  • 2 Reply Likes
Isn't it better to follow the directions in this thread? Worked for me to resolve the blocked-up shadows issue in the Develop module/Camera Raw.
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
None of the 3 options make any difference at all to me.  It still wont render noise reduction or sharpening on fit or fill.
Photo of Davi Siqueira Silva

Davi Siqueira Silva

  • 3 Posts
  • 1 Reply Like
It's the same for me too: None of the 3 options made any difference to me.
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes
Instructions did not work for me. Setting GPU preferred system = "OpenGL" changed "Metal" to "OpenGL" in Performance tab but noise reduction effect not displayed anyway. macOS 10.13 (completely updated), GT650m.
Photo of Greg Priestley

Greg Priestley

  • 7 Posts
  • 0 Reply Likes
I've got the same issue, but I'm on a MacBook Pro 15" Late 2016 with macOS Sierra 10.12.6

I can't see how it's a driver issue if it's across macOS and Windows?

Turning off the "Use Graphics Processor" option resolves the issue.
Photo of Ad Dieleman

Ad Dieleman

  • 31 Posts
  • 2 Reply Likes
No problem for me, tried several Sony A7(R2) raws with Lightroom Classic CC on macOS Sierra 10.12.6, pulled the Luminance slider back and forth between 0 and 100 % and clearly saw the effect in the "Fit" view. I applied this fix (marked as official for a different issue).
(Edited)
Photo of torbjörn samuelsson

torbjörn samuelsson

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Noise reduction does not apply.

When applying noise reduction to an image you can only see the noise reduction tale effect if your zoomed in to 1:1. When you zoom out again the noise reduction is not applied.
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
Just to update, the latest Nvidia drivers came out today, ive installed them and the same issue so thats 4 sets ive tried now.
Im firmly convinced this isn't a driver issue - its a lightroom issue.  Especially as it effects both windows and apple (which is rare).
Its also not just noise reduction - its sharpening not updated as well (but thats harder to see on fit and fill than NR is).
(Edited)
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
UPDATE: So I've trying different things and here is what I see,

1:1 vs 1:2 vs 1:3 vs 1:4
NR results shown in 1:1 1:2 and 1:3 but not in 1:4.

Camera Calibration
There are 4 process version under camera calibration. The current version is 4 and I am guessing the previous version(before updating to LRCCC) was 3. NR results shown in only version 2. Not even version 3 :|

Moving sliders very fast :)
When I move any slider(even HSL sliders) real fast, when the slider is moving, the NR results show. Then it almost instantly goes away. Its almost as if it is being rendered to look crappy.

Camera
Raw
I tried RAW files from my 5Dm4(30mp), X-E1(16mp) and 70D(20mp)....guess what...the 70D files work just fine!!!! This is really frustrating cos I only upgraded to the 5dm4 about a month ago.
 
As for the Fuji, I usually don't shoot raw with my xe1, so dont know if this issue was present with the Fuji RAW before LRCCC...maybe its an xtrans thing. Then again, the 5dm4 RAWs may be weird because of the Dual Pixel Raw option(although i am not using DPR)

Anyone else seeing the above?

Please please tell me that people with this issue are not 5dm4 users. That would almost be funny...unfortunate, but funny.

All my drivers are up to date. I'm using windows 10 and GTX driver 388

Tomorrow m gonna hook up the PC to the TV(4K) via hdmi(no DVI) and see what happens.

On a side note, my monitor is 1920x1200 and I changed resolution to 1920x1080 + restart. Lightroom wont even open. It just kept crashing.
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
I see your point but you are missing a key point everyone is saying - before LRCCC this was not an issue.

I certainly didnt have this issue LR6. This is a post LRCCC issue visible to some users.

Also, your arguments is true to all settings...not just NR. Highlights, shadows, blacks whites, tone curves etc.....they are all done at 1px wide and everything is an approximation at "fit" view because, technically lightroom can not show true highlights, shadows, blacks, whites, tone curves etc at "fit". 

 
Photo of eartho

eartho

  • 723 Posts
  • 177 Reply Likes
Noise reduction and sharpening are completely different than those other adjustments. That little ! in the details panel has been there since v1 or 2 so that people would understand why their images don't look right at Fit view.

Everyone's been complaining about speed for years now and the main contributor to sluggishness in Develop has always been the NR. I imagine to speed things up they've modified the render so that it's not wasting cycles to display an incorrect view. 

Again, there's no point in looking at NR when zoomed to fit. You HAVE to be viewing at 1:1 or looking at the Detail panel preview.
Photo of Hasitha Samarajeewa

Hasitha Samarajeewa

  • 15 Posts
  • 10 Reply Likes
I disagree. Light, shadows, whites and blacks directly show dynamic range, and if it can not be approximated correctly at "fit", there would be obvious banding across all images. Everything at "fit" is an approximation and maybe adobe decided to drop NR approximation for what ever reason in the new version.

I have never had performance issue with noise reduction. If anything, the performance issues were more prominent in filters, masks and spot removal.

Also on the "!" it says "for more accurate....." which means there is an less accurate, but still visible NR at "fit"....which it doesnt have anymore.
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
I dont think they decided to drop it because it works without GPU acceleration so clearly the feature is still there, just doesn't work any more.  Also nothing in the changelog or notes about it so im going for bug.
Im gathering eartho doesnt use the features which is fair enough, everyone has a different workflow.  However for me the approximation is "near enough" to get me started and culling and serves as a quick way to make adjustments before going in to 1:1.  Its a big part of my overall workflow (and id argue you cant see how an image looks overall scrolling across it in 1:1 looking at snapshots in a zoomed window)
Quite simply, the feature worked perfectly on the previous version and still works now without GPU acceleration.  Unfortunately, turning GPU acceleration off makes the already fairly poor performance even worse so its not a satisfactory work around.

As a side question, is anyone experiencing this bug with an accelerated GPU that ISNT nvidia? (AMD etc)? 
Photo of Jerry Syder

Jerry Syder

  • 179 Posts
  • 88 Reply Likes
It has been confirmed as a bug
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes
Tried different images. Cropped file to 2606 x 1737 - NR displayed correct in FIT. Cropped file to 4386 x 2467 - NR not displayed in FIT.
Photo of eartho

eartho

  • 730 Posts
  • 179 Reply Likes
You can't see noise reduction if your images are only displaying at 25%. Noise is a per pixel change in an image and there's no way to see how reduction works unless you're at 100%.  
Photo of Andrey Efimkin

Andrey Efimkin

  • 8 Posts
  • 4 Reply Likes
@eartho, I am understood Your explanation, but I see a big difference between old LR6 (CC) and new LR Classic. By the way, I clearly see noise reduction effect on my Mac book retina display even at 25%.
(Edited)
Photo of Richard Whitcombe

Richard Whitcombe

  • 13 Posts
  • 14 Reply Likes
Except you can see NR in fit and fill modes, you've been able to see the estimate of it for the last few years in lightroom and you can still see it if you turn off GPU acceleration in the menu.  Its a bug.
Photo of Ander Alegría

Ander Alegría

  • 8 Posts
  • 2 Reply Likes
eartho, would you shut up already? No, everyone but you is not a moron who never used LR. I've been using it for over 10 years, so enough.
Photo of Rudi

Rudi

  • 8 Posts
  • 1 Reply Like
Same problems here on macOS High Sierra and LR Classic (macbook pro and iMac). A lot of images show high color noise in Develop module. When switching to Library module the are OK. The whole detail panel (sharpness and noise reduction) doesn't work then.

I tried to find our what's the reason (and please don't tell me I have to view on a certain percentage to not have the color noise). Some images I have set high WB values. When I reduce WB noise goes away and noise sliders work as usual. The break point was 20.401. Might be just by accident. But then I also have images where WB doesn't play a role with color noise. When I reset the tone controls noise also goes away.

Other than this buggy behavior I don't see any improvement of the new develop process (OK, the numbering). I'm a bit angry as I now spent several hours of beta testing instead of being productive. Any quality control for LR classic at Adobe?
Photo of Rudi

Rudi

  • 8 Posts
  • 1 Reply Like
Update: This error only occurs in process version 3+4 (i.e. as soon as you move any slider in version 3 the process version automagically adjustes to version 4!!!

When I switch to process version 2 the noise is gone and everything works as before Classic. So what is the real reason of process version 4???
Photo of Sascha Reinking

Sascha Reinking

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic CC: All my images look grainy and it crashes all the time.

After I upgraded from Lightroom CC to Lightroom Classic CC all my images look grainy. Even when shot at ISO 100. It is really disturbing and I'm not sure what to do. I never had that issue with older LR versions. I updated older catalogs and the issue is the same with those photos. Images that looked great are all grainy now. 

Also, LR Classic crashes at least 4-5 times while editing a wedding. So annoying. Anyone having similar issues? Or know how to correct them?