LR Classic missing after Creative Cloud Desktop App update

  • 1
  • Problem
  • Updated 2 months ago

So, noticed that my copy of Adobe Creative Cloud Desktop App (ACCDA) was getting an update. Fine. I do not remember the previous version. New or at least current version installed reports as v 4.9.0.504

Was working in Lightroom Classic at the time (was just looking at the menu structure to answer a forum members issue, not actually accomplishing anything)

Closed Lightroom, walked away for awhile. Came back to shut PC down, noticed  missing icons in Desktop and Taskbar (Windows 10) . Hmm LR Classic icons. Unknown Update? New Icon over on left side of screen? No icon. Ok,recreate one, nope no executable to link. Program missing.

LR Classic Program folder Not in Recycle.

Did not update, only knew of the Creative Cloud Desktop App update, PS Ok, LR Cloud OK, Bridge OK, LR Classic not Ok.

In the Adobe Creative Cloud Desktop App it states Lightroom Classic is installed (yes the Classic)

Hmm, Ok, signed out at Adobe Creative Cloud Desktop App (And Forum). Signed in. No change

Yes, rebooted, no change.

So, in ACCDA scrolled back down to Lightroom Classic, went into Manage, Uninstalled. Ok, then Install, Ok. LR Classic is back

What the heck?

Previous ACCDA v? I do not remember
Previous LR Classic v8.3.1
Current LR Classic v8.3.1


Photo of David Golding

David Golding

  • 78 Posts
  • 4 Reply Likes

Posted 2 months ago

  • 1
Photo of David Golding

David Golding

  • 78 Posts
  • 4 Reply Likes
P.S. System Info as follows:

Lightroom Classic version: 8.3.1 [ 201905241238-dcd7e2de ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.18362
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 4.0 GHz
Built-in memory: 16317.1 MB
Real memory available to Lightroom: 16317.1 MB
Real memory used by Lightroom: 1287.3 MB (7.8%)
Virtual memory used by Lightroom: 1472.3 MB
GDI objects count: 692
USER objects count: 2286
Process handles count: 2037
Memory cache size: 56.2MB
Internal Camera Raw version: 11.3 [ 197 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 411MB / 8158MB (5%)
Camera Raw real memory: 417MB / 16317MB (2%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: Yes, External touch: No, External pen: Yes, Keyboard: No

Graphics Processor Info:
DirectX: NVIDIA GeForce GTX 1070 Ti (26.21.14.3136)



Application folder: C:\Program Files (x86)\Adobe\Adobe Creative Cloud\ACC\Adobe Lightroom Classic
Library Path: W:\Active Projects\Photography\test\test-2.lrcat
Settings Folder: C:\Users\goldi\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) AdobeStock
2) Aurora HDR 2018
3) ColorChecker Passport
4) Flickr
5) HDR Efex Pro 2
6) Helicon Focus Export
7) Iridient X-Transformer
8) Loupedeck
9) Luminar 2018
10) Nikon Tether Plugin
11) ON1 Photo RAW 2019
12) ON1 Resize 2019
13) SmugMug
14) Teekesselchen

Photo of David Golding

David Golding

  • 78 Posts
  • 4 Reply Likes
Application folder: C:\Program Files (x86)\Adobe\Adobe Creative Cloud\ACC\Adobe Lightroom Classic

Wonder if when I looked for the program I was looking in the wrong place, But then why did the OS not be able to launch LR Classic (tried double clicking on an catalog), And the ACCDA could not launch it.

hmm, should have included:

Tried launching LR Classic after icons went missing via using the ACCDA, and clicking on OPEN (nothing happens, nothing, no launch, no error)

Tried launching LR Classic after icons went missing via double clicking on a catalog (and note that catalog was locked, crash??), yes, deleted lock file
(Edited)
Photo of David Golding

David Golding

  • 78 Posts
  • 4 Reply Likes

Application folder: C:\Program Files (x86)\Adobe\Adobe Creative Cloud\ACC\Adobe Lightroom Classic


That path just bothers the heck out of me. Why in (x86)


So, looking at ACCDA, in its preferences, App file locations was in (x86)


Changed that to C:\Program Files\Adobe\Adobe Creative Cloud


Using ACCDA uninstalled LR Classic


Looked at C:\Program Files (x86)\Adobe\Adobe Creative Cloud\ACC and the "Adobe Lightroom Classic" folder is gone


Reinstall LR Classic


Yes, it is now where I would have expected it to be '


Application folder: C:\Program Files\Adobe\Adobe Creative Cloud\Adobe Lightroom Classic


Photo of Anthony Blackett

Anthony Blackett

  • 177 Posts
  • 53 Reply Likes
David, on my Windows 10 Pro 64bit system, Lr Classic is installed in:

"C:\Program Files\Adobe\Adobe Lightroom Classic"

I don't think it's ever been installed in a path that contains "Adobe Creative Cloud" or "ACC".

From the very start of using Lr 1.0 and all its subsequent versions up to 8.3.1, I've just used the default install location which I'm assuming is the path where it is installed now.

Why it would be installed anywhere under C:\Program Files (x86) on a 64bit system is very strange.

My Creative Cloud App version is 4.9.0.504 and I don't recall it updating recently.

Sorry, it doesn't help you very much.

Tony.