Lightroom Classic: Lossy DNG compression stopped working on macOS 10.15 Catalina

  • 1
  • Problem
  • Updated 5 days ago
  • Acknowledged
  • (Edited)
Since Catalina, option to export and to Use Lossy Compression doesn't seem to work no matter the camera raw compatibility?
Photo of MARKO ERCEGOVIC

MARKO ERCEGOVIC

  • 2 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6682 Posts
  • 1503 Reply Likes
It appears to be working for me Marko. What happens when you try? Error? Silent Failure? Something else?
Photo of MARKO ERCEGOVIC

MARKO ERCEGOVIC

  • 2 Posts
  • 0 Reply Likes
I just discovered it works for me too, if I use the export preset I made before, but if one starts fresh from lr export presets, the tick box Use Lossy Compression doesnt seem to respond. Its probably just gui bug?
Photo of Chinoy Gupta

Chinoy Gupta, Employee

  • 83 Posts
  • 38 Reply Likes
Hi Marco,

I am also able to reproduce this issue. Once I click on an Export Preset, I am not able to check "Use Lossy Compression". We will file a bug and investigate it further.

Thanks,
Chinoy
Photo of Smit K

Smit K, Employee

  • 266 Posts
  • 136 Reply Likes
Hi,

We have logged a bug for this and this happens on both Windows and macOS (Catalina and older)

Thanks,
Smit
Lightroom Classic team
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6682 Posts
  • 1503 Reply Likes
Updates to Lightroom Classic, Camera Raw, and the Lightroom Ecosystem were released yesterday and contain a fix for this issue.  Please install the appropriate update and see if it solves this problem. You can read more about the updates here.

Thank you for your patience.