Lightroom Classic: Won't start up on macOS

  • 2
  • Problem
  • Updated 12 months ago
  • (Edited)
Hello lovely people,

Today for some reason LR CC Classic on my IMac won't work.
After opening any catalogue (even a brand new one) the wheel starts spinning and spinning and the catalogue won't open.

I tried the followings:

- Rebooting the computer
- Turning the computer on and off
- Logging out and back in of Adobe Creative 
- Uninstalling LR and reinstalling

My IMac is up to date by the way. 

Does anybody know what could be causing this? 

Thank you in advance for your time!

Photo of Gabri


  • 1 Post
  • 0 Reply Likes

Posted 12 months ago

  • 2
Photo of Carlos Cardona

Carlos Cardona

  • 634 Posts
  • 122 Reply Likes
Probably a corrupt cache or application state. Please give your Mac the "once over"! Run the free Onyx (, reboot. (In Onyx just run almost everything in the Maintenance tab, deselecting things you may not want deleted, like Launch Services . Hit the "Options" button and deselect more stuff like Cookies & Other Site Data, Browser History, Form Values, etc.), then hit Run Tasks. After it's done it will ask for a reboot.

Run Disk Warrior if you can ($120),  (, reboot. If you can’t do Disk Warrior, at least run First Aid from Disk Utility. Also just doing a "Safe Boot" can clear out caches (restart, hold down shift until you see "Safe Boot" on the screen, then reboot normally.

If that doesn’t work try launching Lightroom from your other (admin or test) account, with a new catalog, as a test. Does it run OK?  If it does it may be a corrupted preference in your Username/Library folder. Check The Lightroom Queen site for instructions on how to reset your preferences ( 

Photo of kanheiya Agrawal

kanheiya Agrawal, Employee

  • 5 Posts
  • 0 Reply Likes
Hi Gabri,

Did above solution provided by Carlos worked?