Lightroom Classic: Import Video - Missing camera make & model metadata

  • 4
  • Problem
  • Updated 1 month ago
  • (Edited)
I import GoPro Videos (GoPro Hero 7 Black) into LR Classic CC 8.0, Build 1193777. 
LR is not setting the camera make and camera model metadata for these videos.
When I import Videos from iPhone 7 plus it will set the model, but not the camera make.

How to set these metadata afterwards (as a workaround)? But there cannot be defined presets for these metadata.
What to do?
Photo of Björn Beeli

Björn Beeli

  • 4 Posts
  • 1 Reply Like

Posted 1 year ago

  • 4
Photo of Ruby k

Ruby k, Employee

  • 23 Posts
  • 14 Reply Likes
Thanks for reporting the issue Bjorn, Can you please share few sample files with us with which issue is reproducible? Is it happening with all files? Please share your OS details as well.
Photo of Björn Beeli

Björn Beeli

  • 4 Posts
  • 1 Reply Like
Hey Ruby
I shared some files in my dropbox - see comment below. 
Can you reproduce the issue?
Photo of DigitalOxygen.ca

DigitalOxygen.ca

  • 30 Posts
  • 9 Reply Likes
I am also experiencing this issue with GoPro Hero 4 footage in LR Classic CC (latest version as of Mar 8, 2019).  Was a solution found for this? Do you still need more samples?
Photo of tpnotes

tpnotes

  • 73 Posts
  • 15 Reply Likes
It is the same with video files from Olympus OMD E-M1 (Mark I and II) and GoPro Hero4 silver: no camera or lens metadata are available/displayed in Lightroom.

Since the metadata are not displayed with other software (e.g. FCPX) as well, I am not sure, if it is a problem of Lightroom. But I would be very happy, if Lightroom could display those information and if they are available for filtering. This is one of two reasons, why I completely stopped using Lightroom for video files.

I am currently on macOS Mojave, but noticed the issue at least two years ago.
Photo of Björn Beeli

Björn Beeli

  • 4 Posts
  • 1 Reply Like
Hey Ruby, you will find the sample files in my dropbox folder.
There you find samples videos from different GoPro and two Sony Cameras.
When I wanted to import today the new sample, none of them where imported the first time.
Error: something like connection to dynamic link server failed (see screenshot in dropbox)
After rebooting of the mac, the import was successful except of the missing metadata for the GoPro cameras. That seems to be another problem.
You will find also the OS details: LR_system_info.txt

Question: how can I add by hand the missing camera infos? Because it can happens also in the future, that   the camera is not recognised.

I hope you will find a solution for the problem, because I was upgrading from LR 6 to LR classic CC to solve the importing problem...
Photo of Björn Beeli

Björn Beeli

  • 4 Posts
  • 1 Reply Like
Hey Ruby
Did you find a solution?
How can I set afterwards the missing metadata?
Photo of Antoine Hlmn

Antoine Hlmn

  • 674 Posts
  • 178 Reply Likes
This reply was created from a merged topic originally titled Lightroom: When importing video’s it does not show camera type as is the case wit....

Got the same issue on classic:



Only a handful of cameras are detected.
Amongst the not detected:
  • Pentax K3
  • Parrot Anafi
  • DxO One
  • GoPro Hero 7 Black
  • ...
Cheers

Note: This conversation was created from a reply on: Lightroom: When importing video’s it does not show camera type as is the case wit....
Photo of agnieszka wiklendt

agnieszka wiklendt

  • 2 Posts
  • 0 Reply Likes
cross-comment from another thread (not sure if this is allowed? i'm assuming no x-post, but comments?):

Using Lightroom Classic CC 8.4.1. Software does not recognise Olympus OMD E-M10 as creator for video files created in that device (lists as "unknown device") when selecting "Camera" in Metadata library filter. Also capture time is incorrect. Does not display "Camera Serial Number" for same.

Same issue with Huawei Mate 20 phone, although capture time is correct, LR does not recognise device as creating the video. 

For Panasonic DMC-FT30, LR recognises camera for both JPG and MP4, but only serial number for JPG. MP4 are listed as "unknown camera serial number" in library filter "Camera Serial Number", even though DMC-FT30 is listed as the "Camera" in filters.
(Edited)
Photo of Ruby k

Ruby k, Employee

  • 23 Posts
  • 14 Reply Likes
Hi , we are able to reproduce this issue with provided videos, we will be looking into it and provide update once we have some. Thanks.