Lightroom Classic: Import Video - Missing camera make & model metadata

  • 2
  • Problem
  • Updated 1 week ago
  • (Edited)
I import GoPro Videos (GoPro Hero 7 Black) into LR Classic CC 8.0, Build 1193777. 
LR is not setting the camera make and camera model metadata for these videos.
When I import Videos from iPhone 7 plus it will set the model, but not the camera make.

How to set these metadata afterwards (as a workaround)? But there cannot be defined presets for these metadata.
What to do?
Photo of Björn Beeli

Björn Beeli

  • 4 Posts
  • 0 Reply Likes

Posted 4 weeks ago

  • 2
Photo of Ruby k

Ruby k, Employee

  • 9 Posts
  • 4 Reply Likes
Thanks for reporting the issue Bjorn, Can you please share few sample files with us with which issue is reproducible? Is it happening with all files? Please share your OS details as well.
Photo of Björn Beeli

Björn Beeli

  • 3 Posts
  • 0 Reply Likes
Hey Ruby
I shared some files in my dropbox - see comment below. 
Can you reproduce the issue?
Photo of tpnotes

tpnotes

  • 54 Posts
  • 7 Reply Likes
It is the same with video files from Olympus OMD E-M1 (Mark I and II) and GoPro Hero4 silver: no camera or lens metadata are available/displayed in Lightroom.

Since the metadata are not displayed with other software (e.g. FCPX) as well, I am not sure, if it is a problem of Lightroom. But I would be very happy, if Lightroom could display those information and if they are available for filtering. This is one of two reasons, why I completely stopped using Lightroom for video files.

I am currently on macOS Mojave, but noticed the issue at least two years ago.
Photo of Björn Beeli

Björn Beeli

  • 4 Posts
  • 0 Reply Likes
Hey Ruby, you will find the sample files in my dropbox folder.
There you find samples videos from different GoPro and two Sony Cameras.
When I wanted to import today the new sample, none of them where imported the first time.
Error: something like connection to dynamic link server failed (see screenshot in dropbox)
After rebooting of the mac, the import was successful except of the missing metadata for the GoPro cameras. That seems to be another problem.
You will find also the OS details: LR_system_info.txt

Question: how can I add by hand the missing camera infos? Because it can happens also in the future, that   the camera is not recognised.

I hope you will find a solution for the problem, because I was upgrading from LR 6 to LR classic CC to solve the importing problem...
Photo of Björn Beeli

Björn Beeli

  • 4 Posts
  • 0 Reply Likes
Hey Ruby
Did you find a solution?
How can I set afterwards the missing metadata?