Lightroom Classic 7.4: Smart Previews White Balance turns turns image very greenish

  • 6
  • Problem
  • Updated 2 months ago
  • Acknowledged
  • (Edited)
When setting the WB of a smart preview (original placed in an external HDD and disconnected), the photo turns turns very greenish.

I have been able to reproduce for Sony A7III raw files with 2 specific lenses (with a different lens it works fine):
- Sigma 50mm F1.4 DG HSM Art 018.
- Sony FE 25-105mm F4 G OSS.

Steps:
1. Import Standard + Smart Previews.
2. Place original in external HDD.
3. Disconnect HDD.
4. Select photo and develop.
5. Set the WB (from menu or modify any slider).
6. It turns very greenish.
7. If the HDD is connected back, the photo turns OK.

Versión de Lightroom Classic: 7.4 [ 1176617 ]Licencia: Creative Cloud
Configuración de idioma: es-ES
Sistema operativo: Mac OS 10
Versión: 10.13.6 [17G65]
Arquitectura de la aplicación: x64
Cantidad de procesadores lógicos: 8
Velocidad del procesador: 2,9 GHz
Memoria incorporada: 16.384,0 MB
Memoria real disponible para Lightroom: 16.384,0 MB
Memoria real usada por Lightroom: 3.073,5 MB (18,7%)
Memoria virtual usada por Lightroom: 6.872,2 MB
Tamaño de memoria de caché: 1.483,9MB
Revisión interna de Camera Raw: 976
Número máximo de subprocesos que usa Camera Raw: 5
Optimización de SIMD de Raw de cámara: SSE2,AVX,AVX2
Memoria virtual de Camera Raw: 458MB / 8191MB (5%)
Memoria real de Camera Raw: 482MB / 16384MB (2%)
Pantallas: 1) 3840x2400

Información de procesador gráfico: 
Metal: AMD Radeon Pro 560



Carpeta de la aplicación: /Applications/Adobe Lightroom Classic CC
Ruta de la biblioteca: /Users/mpovedano/Pictures/Lightroom/Lightroom Catalog.lrcat
Carpeta de ajustes: /Users/mpovedano/Library/Application Support/Adobe/Lightroom

Plugins instalados: 
1)  Plug-in de conexión al equipo de Nikon
2) Adobe Stock
3) Facebook
4) Flickr
5) Plugin de conexión al equipo de Canon
6) Plugin importador de Aperture/iPhoto

Indicadores config.lua: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Salida integrada
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: 10.0x7
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon Pro 560 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-1.68.20
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc 
 
Photo of Miguel Povedano

Miguel Povedano

  • 20 Posts
  • 4 Reply Likes

Posted 9 months ago

  • 6
Photo of Charles Sternaimolo

Charles Sternaimolo

  • 11 Posts
  • 3 Reply Likes
Just completed editing a wedding that was sent to me in a catalogue with smart previews.  Asked the sender to not label any files green.  I didn't have any issues.  So I have narrowed the issue down to the use of filters and smart previews when the images are not on the same hard drive.  The green filter is obviously the main culprit and switching back from Develop to Library although as I've mentioned previously, the red filter and blue filter have given me some not as dramatic issues.  Would love to hear back from a LR rep regarding this as I am unable to color filter images to show a client. 
Photo of James Nonov Urbusniz

James Nonov Urbusniz

  • 3 Posts
  • 0 Reply Likes
Are you saying that if you, for example, have photos in LR on one computer, apply a filter on it, and THEN Create Smart Preview, it screws it up?

So a better way would be to:

1. Import Photos
2. Generate Smart Previews
3. Apply Filter separately on the other computer on the Smart Previews.

Is this right?
Photo of Charles Sternaimolo

Charles Sternaimolo

  • 11 Posts
  • 3 Reply Likes
I work remotely from where the original files are located.  The catalog is sent to me via Dropbox with smart previews from a photographer for me to edit.  He has some files labeled green as they are favorites that he may have done some tweaking to already.  As soon as I start working on one of the files highlighted green, and especially if I toggle from Library to Develop or via versa, a funky dark olive green hue starts affecting that file, as well as a handful of other files - making them hard to view.  Once this happens I am unable to use LR to show images to a client as they can't see some of the images through the dark green.  I have a similar issue to a much lesser extent with the red and blue highlight filter.  I have not found a workaround other than to ask the photographer sending the files to not highlight any smart preview files with a color, esp. green.  Totally messes with our workflow.
(Edited)
Photo of James Nonov Urbusniz

James Nonov Urbusniz

  • 3 Posts
  • 0 Reply Likes
Has this still not been fixed?
Photo of Katie Phillips

Katie Phillips

  • 6 Posts
  • 7 Reply Likes
Any news on when this issue is going to be resolved?