Lightroom Classic: Can Select the Wrong Image on Windows

  • 3
  • Problem
  • Updated 1 month ago
  • (Edited)
From a post on the LR general forum:

This appears to be a UI bug on Windows that is causing me enormous frustration and errors.

In
any app that allows mouse selection, it is common to mouse click and then move to a button, menu etc.  Or, shift+click and then move to perform an action.  Because of the poor performance of LR, it is quite common to move the mouse before LR gets around to processing the click.


When you click the mouse button to select a image (or shift+click to mark the end of a range of selected images), there is sometimes a ~1 second lag before LR responds to the event.  That in and of itself is not a bug.  However when LR gets around to processing the click event, it appears to read the current mouse coordinates, rather than those packaged with the event.  If you have moved the mouse after clicking, it will select the wrong image.


This has caused me to incorrectly tag images, and sometimes inadvertently delete the wrong image.


The machine is fairly high-end (Core-i7 with 8 physical cores; 32gb RAM; GeForce GTX 1060 video card with 6gb; system, catalog and cache all on SSDs).  I have performed all the performance tricks suggested by Adobe.  My catalogs typically have 5,000-10,000 images.


I am seriously considering looking at alternatives because of the frustration caused by this bug.


Are there any suggestions out there, or is there some way to get Adobe to fix this bug?


Thanks,
Rich



https://forums.adobe.com/message/10770268#10770268
Photo of Richard Devitt

Richard Devitt

  • 4 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 3
Photo of Marco Klompalberts

Marco Klompalberts

  • 70 Posts
  • 17 Reply Likes
I have the same problem, but was thinking it is my (older) computer that is lagging.
So when selecting multiple images I know I have to wait after my second click (any click after that seems fine (most of the time))

Was hoping a newer computer would solve this, but now I am afraid it won't ...
Photo of Sreenivas Ramaswamy

Sreenivas Ramaswamy, Employee

  • 39 Posts
  • 14 Reply Likes
Hi Rich,

can you share a screen recording of the issue? It would help us in understanding the exact behavior.

Thanks

Photo of Marco Klompalberts

Marco Klompalberts

  • 70 Posts
  • 17 Reply Likes
I don't hink a screenshot will help, because it doesn't show what photo is clicked on and what photo is selected.
I don't know how to make a screenmovie, but that might help ...

Photo of Marco Klompalberts

Marco Klompalberts

  • 70 Posts
  • 17 Reply Likes
I was able to create a screencapture (movie)
In the movie, I selected #776, then CTRL clicked #777 and CTRL clicked #778.
But since I moved the cursor away from #778 before the click was registered, #779 was selected. Even though I DID NOT click #779
Photo of Sreenivas Ramaswamy

Sreenivas Ramaswamy, Employee

  • 39 Posts
  • 14 Reply Likes
Hi,

thanks for the video. We will work on fixing this.