Lightroom Classic 9.2.1: Inconsistent display of presets panel content (dev module)

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Hi everyone,

First time I am posting here because I have not found the answer inexisting threads. I am seeking for fix or workaround thatwould avoid me to reinstall lightroom (assuming this would solve the issue).

I use lightroom classic 9.2.1 on Windows 10. See all system details at theend of this post.

Here is the detailed sequence.

I have recently purchased presets and profiles from Really Nice Images (RNIAll Films 5 – Pro product) and installed them successfully by unzipping theirzip package and copying the resulting folder in the ‘‘/lightroom settings/settings’ like my other presets (the ‘storepresets with this catalog’ option in Edit/Preferences is checked). Seeattachment 1 with a screenshot of the content of this ‘settings’ folder.




After this installation, in the dev module, the presets were available inthe presets panel (provided they are checked in the ‘manage presets’ menu) andthe profiles were also available in the profile browser. This validates theywere installed correctly I believe.

But after one day, I had to save my first user preset (through the ‘+’ signof the presets panel) which I created from one of the available RNI presets.But when saving this preset, I chose to save this new user preset in a newgroup called RNI, to distinguish this new RNI based user preset from the onescreated in the past without RNI (in group called ‘user presets’).

And this is where the problem started.

From this point on, the display of the presets panel became inconsistentunless I unchecked all RNI presets from the ‘manage presets’ menu of the presetpanel. By inconsistent, I mean the RNI presets are no longer accessible ifchecked. And thedisplay of the presets panel is either:

  • A truncated display of the presets list when the presets panel is expanded. In the presets panel screenshot below, I should see the expanded list of presets in the My VSCO & LR presets.



  • a display of the other modules if I went in one of them before returning to the dev module (I can see part of the catalog tree from library module or print sheet from the print module through the presets panel frame...).
 


  • a duplicate display of the other panels located below the presets panel (like history, snapshots). See screenshot below.



In the meantime, the profiles remain fully available and operational fromthe profile browser of the dev module.

The presets panel behavior comes back to normal (but without RNI presets)as soon as I uncheck all RNI presets from the ‘manage presets’ menu in the '+'sign of the panel). 

See screenshots below with the correct display of the panel at this point when the RNI presets are unchecked:

 


From there, I tried to find fixes/workaround like:

  • Moving RNI presets and profiles folder and all my other presets to the ‘AppData/Roaming/Adobe/CameraRaw/Settings’ after having unchecked ‘store with this catalog’ in the Edit/preferences.
  • Installing the RNI presets and profiles zip through the ‘File/import develop presets and profiles...’ function
  • Importing RNI presets and profiles through ‘import presets’ function from the '+' sign of the presets panel of the dev module
  • Deleting the ‘index_....dat’ files existing in the ‘settings’ whether it is the ones located in ‘AppData/Roaming/Adobe/CameraRaw/Settings’ or located in ‘/lightroom settings/settings’
Note that when I check/uncheck the ‘store with this catalog’ option,lightroom freezes and I have to for exit. I can workaround the switching thisoption via the preference agprefs.

Note also that I succeeded in creating my new RNI based user preset butonly based on RNI profiles as RNI presets are no longer available as describeabove. So at this point I only get access to RNI profiles, which is quitefrustrating for such a product (192 USD).

Is it a problem in lightroom? In RNI? Of compatibility between both?

Any suggested solution (other than full lightroom reinstallation)?

Any workaround that would help me recover the RNI presets?

Thanks a lot for your support and I hope this thread will also benefit toothers facing the same issue, at least to know that it exists. I also hope itwill help finding a workaround in the short term and if it is confirmed this isa lightroom bug and/or an RNI bug, to have them fix asap.

Congratulations if you were brave enough to read this post up to here :-)

Thank you to all.

Maxime

---

Full System info:

Lightroom Classic version: 9.2.1 [ 202004070813-7699d98a ]

License: Creative Cloud

Language setting: en

Operating system: Windows 10 - Business Edition

Version: 10.0.18362

Application architecture: x64

System architecture: x64

Logical processor count: 16

Processor speed: 3,9 GHz

SqLite Version: 3.30.1

Built-in memory: 32704,5 MB

Real memory available to Lightroom: 32704,5 MB

Real memory used by Lightroom: 3194,3 MB (9,7%)

Virtual memory used by Lightroom: 5917,1 MB

GDI objects count: 1212

USER objects count: 3029

Process handles count: 4021

Memory cache size: 291,9MB

Internal Camera Raw version: 12.2.1 [ 415 ]

Maximum thread count used by Camera Raw: 5

Camera Raw SIMD optimization: SSE2,AVX,AVX2

Camera Raw virtual memory: 1280MB / 16352MB (7%)

Camera Raw real memory: 1303MB / 32704MB (3%)

System DPI setting: 120 DPI

Desktop composition enabled: Yes

Displays: 1) 2560x1440

Input types: Multitouch: No, Integrated touch: No, Integrated pen: No,External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:

DirectX: AMD Radeon Pro WX 3100 (26.20.11002.1001)

Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic

Library Path: C:\Users\CMP QUADRO\Pictures\Lightroom\LightroomCatalog-2-2.lrcat

Settings Folder: C:\Users\CMP QUADRO\AppData\Roaming\Adobe\Lightroom

Installed Plugins:

1) AdobeStock

2) Facebook

3) Flickr

4) Nikon Tether Plugin

5) SmugMug

Config.luaflags: None

Adapter #1:Vendor : 1002

            Device : 6985

            Subsystem : b0c1002

            Revision : 0

            Video Memory : 4077

Adapter #2:Vendor : 1414

           Device : 8c

           Subsystem : 0

            Revision : 0

            Video Memory : 0

AudioDeviceIOBlockSize: 1024

AudioDeviceName: Haut-parleurs (Jabra EVOLVE LINK)

AudioDeviceNumberOfChannels: 2

AudioDeviceSampleRate: 48000

Build: 12.1x4

Direct2DEnabled: false

GL_ACCUM_ALPHA_BITS: 0

GL_ACCUM_BLUE_BITS: 0

GL_ACCUM_GREEN_BITS: 0

GL_ACCUM_RED_BITS: 0

GL_ALPHA_BITS: 8

GL_BLUE_BITS: 8

GL_DEPTH_BITS: 24

GL_GREEN_BITS: 8

GL_MAX_3D_TEXTURE_SIZE: 2048

GL_MAX_TEXTURE_SIZE: 16384

GL_MAX_TEXTURE_UNITS: 8

GL_MAX_VIEWPORT_DIMS: 16384,16384

GL_RED_BITS: 8

GL_RENDERER: AMD Radeon Pro WX 3100

GL_SHADING_LANGUAGE_VERSION: 4.60

GL_STENCIL_BITS: 8

GL_VENDOR:ATI Technologies Inc.

GL_VERSION: 4.6.13559 Compatibility Profile Context FireGL 26.20.11002.1001

GPUDeviceEnabled: false

OGLEnabled: true

GL_EXTENSIONS: GL_AMDX_debug_output GL_AMD_blend_minmax_factorGL_AMD_conservative_depth GL_AMD_debug_output GL_AMD_depth_clamp_separateGL_AMD_draw_buffers_blend GL_AMD_framebuffer_sample_positions GL_AMD_gcn_shaderGL_AMD_gpu_shader_half_float GL_AMD_gpu_shader_int16 GL_AMD_gpu_shader_int64GL_AMD_interleaved_elements GL_AMD_multi_draw_indirect GL_AMD_name_gen_deleteGL_AMD_occlusion_query_event GL_AMD_performance_monitor GL_AMD_pinned_memoryGL_AMD_query_buffer_object GL_AMD_sample_positionsGL_AMD_seamless_cubemap_per_texture GL_AMD_shader_atomic_counter_opsGL_AMD_shader_stencil_export GL_AMD_shader_stencil_value_exportGL_AMD_shader_trace GL_AMD_shader_trinary_minmax GL_AMD_sparse_textureGL_AMD_sparse_texture_pool GL_AMD_stencil_operation_extendedGL_AMD_texture_cube_map_array GL_AMD_texture_texture4GL_AMD_transform_feedback3_lines_triangles GL_AMD_transform_feedback4GL_AMD_vertex_shader_layer GL_AMD_vertex_shader_viewport_indexGL_ARB_ES2_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_compatibilityGL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_bindless_textureGL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_objectGL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_floatGL_ARB_compatibility GL_ARB_compressed_texture_pixel_storageGL_ARB_compute_shader GL_ARB_conditional_render_inverted GL_ARB_conservative_depthGL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_outputGL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_textureGL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffersGL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_indirectGL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_explicit_attrib_locationGL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventionsGL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadowGL_ARB_fragment_shader GL_ARB_framebuffer_no_attachmentsGL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gl_spirvGL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_half_float_pixelGL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_indirect_parametersGL_ARB_instanced_arrays GL_ARB_internalformat_queryGL_ARB_internalformat_query2 GL_ARB_invalidate_subdataGL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bindGL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitextureGL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_parallel_shader_compileGL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_objectGL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_polygon_offset_clampGL_ARB_program_interface_query GL_ARB_provoking_vertexGL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behaviorGL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_mapGL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objectsGL_ARB_shader_atomic_counters GL_ARB_shader_ballot GL_ARB_shader_bit_encodingGL_ARB_shader_draw_parameters GL_ARB_shader_group_voteGL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precisionGL_ARB_shader_stencil_export GL_ARB_shader_storage_buffer_objectGL_ARB_shader_subroutine GL_ARB_shader_texture_image_samplesGL_ARB_shader_texture_lod GL_ARB_shader_viewport_layer_arrayGL_ARB_shading_language_100 GL_ARB_shading_language_420packGL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_shadow_ambientGL_ARB_sparse_buffer GL_ARB_sparse_texture GL_ARB_spirv_extensionsGL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shaderGL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_ARB_texture_buffer_objectGL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_rangeGL_ARB_texture_compression GL_ARB_texture_compression_bptcGL_ARB_texture_compression_rgtc GL_ARB_texture_cube_mapGL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combineGL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_floatGL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edgeGL_ARB_texture_mirrored_repeat GL_ARB_texture_multisampleGL_ARB_texture_non_power_of_two GL_ARB_texture_query_levelsGL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rgGL_ARB_texture_rgb10_a2ui GL_ARB_texture_snorm GL_ARB_texture_stencil8GL_ARB_texture_storage GL_ARB_texture_storage_multisampleGL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_queryGL_ARB_transform_feedback2 GL_ARB_transform_feedback3GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_queryGL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgraGL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bitGL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_programGL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_revGL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffersGL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_meminfoGL_ATI_separate_stencil GL_ATI_texture_compression_3dcGL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_onceGL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_colorGL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmaxGL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_bufferGL_EXT_copy_texture GL_EXT_depth_bounds_test GL_EXT_direct_state_accessGL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elementsGL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisampleGL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_histogramGL_EXT_memory_object GL_EXT_memory_object_win32 GL_EXT_multi_draw_arraysGL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixelsGL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset_clampGL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_colorGL_EXT_semaphore GL_EXT_semaphore_win32 GL_EXT_separate_specular_colorGL_EXT_shader_image_load_store GL_EXT_shader_integer_mix GL_EXT_shadow_funcsGL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3DGL_EXT_texture_array GL_EXT_texture_buffer_objectGL_EXT_texture_compression_bptc GL_EXT_texture_compression_latcGL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tcGL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_addGL_EXT_texture_env_combine GL_EXT_texture_env_dot3GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lodGL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_objectGL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decodeGL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_storageGL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedbackGL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bitGL_IBM_texture_mirrored_repeat GL_KHR_context_flush_control GL_KHR_debugGL_KHR_no_error GL_KHR_parallel_shader_compileGL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_KTX_buffer_regionGL_NV_alpha_to_coverage_dither_control GL_NV_blend_square GL_NV_conditional_renderGL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_floatGL_NV_explicit_multisample GL_NV_float_buffer GL_NV_half_floatGL_NV_primitive_restart GL_NV_texgen_reflection GL_NV_texture_barrierGL_OES_EGL_image GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clampGL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hintWGL_EXT_swap_control
Photo of Maxime Léonard

Maxime Léonard

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 months ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1739 Posts
  • 601 Reply Likes
With all the UI glitches, it could be some indication that Lr has problem when trying to load the two "My RNI presets" that you created.  Try to isolate the problematic preset one by one:

1) Move the "My RNI presets" folder out of the Lightroom Settings>Settings folder to your Desktop folder. And check if things come back to normal.

2) You could also do a right click on each preset and "Show in Explorer" to locate each user preset in question and move it else where.

See what happens after restarting Lr.
Photo of Maxime Léonard

Maxime Léonard

  • 2 Posts
  • 0 Reply Likes
Thank you Simon for your prompt reply.

I removed the presets as you suggested but the problem was still there.

Beside, RNI support advised me to do the following which was successful:
  1. In Edit/Preferences/Presets make sure your 'store with this catalog’ option is unchecked.
  2. Then click both 'Show Lightroom Develop Presets' and 'Show All Other Lightroom Presets' buttons - this will reveal 2 different directories in your Explorer where Lightroom keeps different presets and profiles.
  3. Quit all your Lightroom and Photoshop applications so they won't interfere with the next steps.
  4. Now, from those two folders from p.2 move everything, all folder contents, to some temporary location, say on your desktop.
  5. Launch Adobe Lightroom - make sure it works as expected with no freezings or other nasty things.
  6. Now make a fresh installation of the original RNI presets & profiles, not the ones that you moved. You can install it by either copying the files or the Lightroom's install presets & profiles command.
  7. Launch Lightroom if needed - make sure the RNI presets are not hidden and work as expected.
  8. Now you can try and start returning your stuff (e.g. my older presets other than RNI's) from the temporary location back to its folders restarting Lightroom in between.
As said above, this worked successfully.

Of course, after this procedure I had to restore all my other non-dev presets (print, export, watermark, etc) as they were moved from the 'Show All Other Lightroom Presets'. In addition I rebuilt the prefs (.agprefs file in Lightroom/Preferences folder) from scratch through Lightroom (not from the one I moved out) and in my opinion this is what solved the issue. There was an inconsistency somehow in these .agprefs files.

Anyway, problem fixed, without reinstallation of LR. And this is the most important to me.

I hope these posts will help others who may face this issue.

Thank you again for your support.

Maxime



(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1739 Posts
  • 601 Reply Likes
Thanks for the updates. The procedures above amount to start clean on the Lr presets and reinstall of the RNI presets.

My original suspicion probably still holds. Some preset is bad or corrupted in your earlier setup.