LR CC2015.4 V6.1 - Lightroom edits not being retained after editing PSD or TIFF in Photoshop

  • 4
  • Problem
  • Updated 2 years ago
With prior versions of Lightroom, going back many years, I was able to open a PSD file using "Edit Original" and upon returning to Lightroom after editing and saving the file, the Lightroom edits (i.e. crop) were retained.  This functionality has been lost in the current version.  It is very important to me to be able to edit the original, uncropped PSD file while maintaining the crop after returning to Lightroom. Now, all LR adjustments are reset upon return from Photoshop.  By the way, if the PSD file that was opened from LR "Edit Original" into Photoshop is not saved from Photoshop, the Lightroom edits are maintained.
Photo of Jeff Schneiderman

Jeff Schneiderman

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 4
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 175 Posts
  • 47 Reply Likes
Completely agreed. This seems to be a problem only on the Mac version: https://feedback.photoshop.com/photoshop_family/topics/edit-original-loses-all-lr-adjustments-on-ret...
Photo of Jeff Schneiderman

Jeff Schneiderman

  • 4 Posts
  • 0 Reply Likes
It's a problem on a PC as well - that is the platform I am using.
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 175 Posts
  • 47 Reply Likes
Interesting. Some windows users appear to not have the issue. I wonder what is going on. 
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 175 Posts
  • 47 Reply Likes
Photo of Jeff Schneiderman

Jeff Schneiderman

  • 4 Posts
  • 0 Reply Likes
Thanks for sharing the thread.  Yes, it describes exactly what I experienced both before and after the install of 2015.4  V6.1.  Glad to know others are using similar workflows that use Lightroom's ability to keep it's adjustments after saving the original file from Photoshop.  At least there is a workaround using History in Lightroom to revert to the LR adjustments made prior to the PS edit.  Still - not good losing functionality after an upgrade!
Photo of Jao van de Lagemaat

Jao van de Lagemaat

  • 175 Posts
  • 47 Reply Likes
Photo of Jeff Schneiderman

Jeff Schneiderman

  • 4 Posts
  • 0 Reply Likes
Terrific - thank you!
Photo of Todd Shaner

Todd Shaner, Champion

  • 993 Posts
  • 324 Reply Likes

There's a basic issue with 'Edit Original.'

If you have 'Include Develop settings in metadata inside JPEG, TIFF, PNG, and PSD files' checked and 'Save' (CTRL + S) metadata to the TIFF its XMP-crs Camera Raw Namespace metadata contains LR’s Develop settings. If you choose 'Edit Original' the TIFF opens in PS without the XMP-crs fields, which is why the returned TIFF "loses" the LR edits.

It can be argued that 'Edit Original' means without LR’s settings in XMP metadata, but the original file could have been created using ACR and contain its camera raw data in the XMP-crs fields. That is an “original" file and it contains relevant the XMP-crs data. At the very least it begs an option in LR to retain the XMP-crs metadata when using 'Edit in Photoshop' > 'Edit Original.'

The easiest solution for now is to NOT check the Catalog Settings> Metadata panel option for 'Include Develop settings in metadata inside JPEG, TIFF, PNG, and PSD files.' Alternatively, you can create a Virtual Copy of the TIFF with LR settings and then Sync the Virtual Copy with the original TIFF to restore LR’s Develop settings. This will allow you to use 'Include Develop settings in metadata inside JPEG, TIFF, PNG, and PSD files.'

(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 993 Posts
  • 324 Reply Likes

I tested this using LR 5.7.1 and it exhibits the same 'Edit Original' behavior as LR CC 2015.4. The XMP-crs fields are removed in the file opened in PS and the Develop edits are reset in LR when the file is saved inside PS.

I also tested this using LR 4.4.1 and it does not exhibit this behavior. The XMP-crs fields are removed in the file opened in PS, but the Develop edits are retained in LR when the file is saved inside PS. Somewhere in LR 5 the bug was introduced, then fixed in CC 2015, and broken again in one of the latest CC 2015 updates.

NOTE: This is with the Catalog Settings> Metadata option 'Include Develop settings in metadata inside JPEG, TIFF, PNG, and PSD' checked. With it unchecked there is no issue with 'Edit Original.