Lightroom CC: Insists on selecting two photos, but I am selecting only one photo

  • 1
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
I and someone else posted this new problem to an old thread (about the same issue), but am not seeing any feedback that our comments have been seen.  Here is what I wrote in that old thread:

I agree it is not fixed, it just happened to me!  I was using Compare mode last night on a second monitor.  Now, every time I select a photo to delete it, it tells me that 2 are selected for deletion.  I'm afraid to delete anything because I have no idea what other photo might be selected, if any.  I am closing and backing up Lr now and will see if the problem still exists when I restart it.  I am running the current CC release (just updated a few days ago).

UPDATE:  Closed, backed up, and re-opened Lr CC.  It's still doing it!  At least this time it is showing me which photo is being selected in addition to the one I have selected.

No matter what folder I go to in Library, the first photo is preselected and moments later, Lr also selects the second one (right next to it).  This happens in both the film strip and in grid view.  It continues to happen in the film strip in the Develop module.

If I Ctrl-D, briefly the selections go away, only to come right back again as the first two in the film strip. 

If I select another photo farther down the film strip, the new photo is selected properly but the second photo in the film strip remains selected.

Oh, please fix this.

FYI:  It started happening after following the "second method" procedures in this video tutorial last night (5/29/2017):

https://www.youtube.com/watch?v=OKsxtUUb39I&feature=youtu.be
Photo of Beverly Parks

Beverly Parks

  • 55 Posts
  • 9 Reply Likes

Posted 1 year ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1410 Posts
  • 434 Reply Likes
Official Response
I suspect you have a secondary monitor setup currently in the compare view mode. Try click on the second monitor icon [2] on the left of the filmstrip filterbar to turn off the second display (or you can make sure to physically turn on your secondary display to see if you missed out something on your second display). If you have a single monitor, the second display window might be hidden behind the main window.

If you are not sure, try reset the Lr prefs by holding down Shift+Alt (Windows) or Shift+Option when launching Lr, which will let Lr goes back to the default state (with second display off).
(Edited)