Lightroom CC 2015: Duplicate Published Smart Collection ERROR

  • 3
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
i found this problem report elsewhere and over 3 months without answer. I have the same problem.

I have Lightroom 6.01. The Duplicate Published Smart Collection feature does not work. Whenever I right click on a Published Smart Collection to invoke the Duplicate... command, I get an error message each time I attempt to do this. The error message says "An internal error has occurred. Assertion failed."
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes

Posted 3 years ago

  • 3
Photo of Oleg Namaka

Oleg Namaka

  • 8 Posts
  • 0 Reply Likes
Same here on the latest version 6.1.1.
Photo of Robert Somrak

Robert Somrak, Champion

  • 114 Posts
  • 29 Reply Likes
This is still a problem on Lr6.1.1
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
I was under the impression that Adobe reads these posts.

Wrongly so ?
Photo of Oleg Namaka

Oleg Namaka

  • 8 Posts
  • 0 Reply Likes
It says a lot about Adobe QA process.
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
Hello Adobe, Any reaction ?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
Can you tell us more so we can try to reproduce your issue please? Your operating system would be a great start, and what kind of publish service is it? And if it's a third party plug-in, what's the version number for the plug-in?
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
Victoria, I will, but can't promise when as I am on travel. At the time of writing I was on w8, the then current CC version and using standard Adobe provided export. No plug in.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
Ok, that helps. Standard Adobe provided export... do you mean the Hard Drive Publish Service? Facebook one? Flickr one? Or the normal Export dialog?
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes


Hello, It's on Hard drive export, I was able to reproduce it on 2015.1.1.
Now on W10,
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
I can't replicate this so far. Can you try something... create another Hard Drive publish service, even if it goes to the same location with the same settings, and see if you see the same problem with that?
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
Hi, it seems that my earlier reply did not reach you.

I re-created the problem on another computer than the one I normally use.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
This problem happens to me, with both the built-in Flickr server and the Friedl Zenfolio service. I tried resetting LR's preferences and creating a new catalog, but the problem still occurs. In the new catalog, I set up the Flickr service, authorized with Flickr, made one change to the default settings, resizing to fit 1000x1000, published a new album containing one photo, right-clicked the photo, and invoked Duplicate.

LR CC 2015.1.1 / OS X 10.10.5
Photo of Robert Somrak

Robert Somrak, Champion

  • 114 Posts
  • 29 Reply Likes
This happens to me too on both Duplicate Published Smart Collection and Duplicate Published Collection on newly created Hard Drive and Revel Publish services. I can't get it NOT to show the error. This is on OS X Yosemite and Lr2015.1.1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
Yep, I've got it. I'm not sure which step I was missing but I'll bug it internally..
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
Many, many thanks.
I know that bugs are unavoidable, but I am concerned about the processes and the quality thereof. How could this bug report exist for so long without any visible response until you stepped in.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
Checking up on it, it appears that it's already in the internal bugbase and in progress.
Photo of Oleg Namaka

Oleg Namaka

  • 8 Posts
  • 0 Reply Likes
Any ETA that you can provide on the fix?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
This should be fixed in the latest release
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
Yes it works, but the option is no longer available for published collections
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
Hi Victoria,

Elsewhere on this frum I posten a Q about why NIKON capture NX is able to generate a 1:1 view in less tthan a second, and why it takes LR up to 10s and more.

Would it be possible that an LR person replies to that performance topic?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4128 Posts
  • 1472 Reply Likes
em, that topic was about performance while running an export and should be fixed in 6.3, as I've just posted. And this thread isn't about performance at all. I'd recommend you start a separate thread on the topic.
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
I have created a new topic, for performance, without running anything else.
Photo of Oleg Namaka

Oleg Namaka

  • 8 Posts
  • 0 Reply Likes
Can you link this new topic here?
Photo of Oleg Namaka

Oleg Namaka

  • 8 Posts
  • 0 Reply Likes
Thanks
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
will do
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
Yes, it appears the bug was "fixed" by removing the Duplicate command for published collections.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3589 Posts
  • 928 Reply Likes
Thanks much for the clarification.
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
I don't understand that. The server is only affected after PUBLISH is hit. However, I think that selecting (all pix from) a collection and creating a new one has the same result.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
I couldn't think of a good argument against his logic, but if you guys have a different idea of what should happen, I could run it by the eng.
Photo of em vaningen

em vaningen

  • 68 Posts
  • 6 Reply Likes
I am cool with my work around, but i am not sure of the wisdom to call it "fixed" instead of saying that an option has been removed..
Photo of Oleg Namaka

Oleg Namaka

  • 8 Posts
  • 0 Reply Likes
Doesn't removing it break EULA?
Photo of Oleg Namaka

Oleg Namaka

  • 8 Posts
  • 0 Reply Likes
So, they removed something customers paid for.