Lr 9.2 (classic) issue of vertical/horizontal/rotate zeroing out in transform settings?

  • 1
  • Problem
  • Updated 1 week ago
  • In Progress
  • (Edited)
all of a sudden (after 9.2 update?) now these 3 settings (v/h/r under transform) zero out after making further batch adjustments after clicking on one of the transform presets (auto/level/vertical/full)!?  batch processing/auto-syncing works fine, but then when you deselect the group of successfully adjusted photos, then go into to develop mode on each of those images you just made adjustments to individually...the top 3 sliders (vertical/horizontal/rotate) zero out!?  batch adjustments are very briefly seen, then the 'update' button highlights on its own and it automatically zeros-out v/h/r.  not sure what is causing this?

fyi - the work-around is simply to NOT click on any of the preset buttons (auto/level/vertical/full) and make all your transform adjustments manually.

anyone else experiencing this problem?  any advice, adobe?
Photo of christian phillips

christian phillips

  • 1 Post
  • 0 Reply Likes

Posted 2 weeks ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 4848 Posts
  • 1343 Reply Likes
Note that clicking Transform > Auto, Guided, Level, Vertical, and Full all zero out the Vertical, Horizontal, and Rotate sliders.  I just tried LR 8.2.1 and LR 9.2, and the behavior is the same in both.

If this doesn't explain what you're experiencing, please provide a precise description of the steps you're taking, including screenshots of the Settings window for the Sync Settings or Copy Settings commands.  Your current description omits important details.
Photo of christian phillips

christian phillips

  • 2 Posts
  • 0 Reply Likes
yes...that is correct, john, and i am aware of that.  but sometimes it is necessary to make minor additional v/h/r slider adjustments AFTER clicking one of those preset transform buttons, those settings SHOULD (and HAVE in the past) remain and stay with all those other images in the batch process.  this no longer is the case.

follow this step-by-step process:
- select a batch of images
- make sure 'auto sync' is highlighted
- click the vertical (or auto - or full) preset transform button
- make any random further adjustments to ALL sliders (make drastic adjustments for this exercise)
- go to grid mode to ensure all adjustments are applied to all batched images
- deselect all
- select any one of those images...go to 'develop' mode
- the top 3 sliders (v/h/r) briefly display your adjustments made THEN immediately zero-out!?
- advance to the next image...same happens to the top 3 sliders

??

at least that is what is happening to me. 

let me know what you find happening.

thanks for your reply!
(Edited)
Photo of Arjun Haarith

Arjun Haarith, Employee

  • 117 Posts
  • 35 Reply Likes
Hi Christian,

I followed your steps and the settings retained in my case. It did not zero out in Mac 10.15

However, on Win 10, I was able to reproduce, but this happened only to a few images from a large selection. 
We will look at what caused this and let you know. Thanks for reporting.

Thanks,
Arjun

Photo of christian phillips

christian phillips

  • 2 Posts
  • 0 Reply Likes
interesting.  thanks arjun!  i'm running mac 10.14.6 (mojave)
Photo of Todd Shaner

Todd Shaner, Champion

  • 1717 Posts
  • 581 Reply Likes
However, on Win 10, I was able to reproduce, but this happened only to a few images from a large selection.
I had the same experience on Windows 10. I selected four image files, which did not zero out. Then I selected 20 image files, which did exhibit the issue and zeroed out the Transform settings. When I tried it a 2nd time with the same 20 image files I could not duplicate the issue. Not sure what triggers it, but it's elusive.
Photo of John R. Ellis

John R. Ellis, Champion

  • 4848 Posts
  • 1343 Reply Likes
This issue smells like the bug with applying Auto to a batch of photos. In both situations, if you apply an "auto" setting to a batch of photos and then apply some other setting, the later setting gets erased later on by the "auto".

Christian, if you can reproduce this reliably, you might try the same workaround: After applying Vertical to the batch, go to Library and do the menu command Library > Previews > Build Standard-Sized Previews.