Lightroom Classic 7.3.1: Freezes sporadically in Library Mode when zooming in

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
LR 7.3.1. freezed one time after zooming into 1:1 view in Library mode.

I had used LR 7.3.1 for about 10 min - happy about not crashing during preset handling. I am often switching between Library and Develop modules and zooming in/out regularly. While everything was working fine in Develop module, after switching to Library mode I recognised that zoomed in image did show low res artifacts which is 'normal' for <1s usually then the image quality usually improves. This was never the case while trying to zoom in / out multiple times in loupe or compare ("N") mode. LR showed "loading" on top of the image but never finished. Trying to switch off graphic card performance optimization did not help and after several more zoom operations LR freezed. No crash, no bug protocol, just freezed. Luckily I could force quitting the application. Restart resolved the problem. I will observe and try to reproduce. 

Lightroom Classic version: 7.3.1 [ 1167660 ]License: Creative Cloud
Language setting: en-DE
Operating system: Mac OS 10
Version: 10.13.4 [17E199]
Application architecture: x64
Logical processor count: 4
Processor speed: 3,2 GHz
Built-in memory: 24.576,0 MB
Real memory available to Lightroom: 24.576,0 MB
Real memory used by Lightroom: 6.384,5 MB (25,9%)
Virtual memory used by Lightroom: 14.547,1 MB
Memory cache size: 1.833,5MB
Internal Camera Raw revision: 933
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 788MB / 12287MB (6%)
Camera Raw real memory: 788MB / 24576MB (3%)
Displays: 1) 2560x1440

Graphics Processor Info: 
Metal: NVIDIA GeForce GT 755M

update: the first part (without the freeze) but stopping to show full res images in library mode and only showing "loading" with spinning wheel happens quite often in my use cases when editing images and switching between library and develop modules multiple times, zooming in and out, doing basic image adjustments.

Only restarting LR helps. I guess continuing working without restarting will again result in freezing.
Photo of Sven Kohle

Sven Kohle

  • 39 Posts
  • 24 Reply Likes

Posted 3 months ago

  • 1
Photo of Sven Kohle

Sven Kohle

  • 39 Posts
  • 24 Reply Likes
happens again - multiple times.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3439 Posts
  • 618 Reply Likes
Sven, 

I haven't seen any other reports of this. What is your nVidia driver version number? Does nVidia have a more recent driver available for you to download and install?