LightRoom 6.2 Memory Leak with Win 7 64bit and nVidia Drivers generating Previews

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
HI

Just upgraded to 6.2 from 6.1.1 on a Windows 64bit PC with latest nVidia drivers. I left it doing some preview generation (2 lots of 10,000 images), and it basically uses all the memory available until it causes Windows memory issues. I have 32GB, and I killed the previews when it got to about 28GB. I also seemed to have to quite LR before it freed up the memory, but perhaps I didnt give it enough time.

I uninstalled, then reinstalled 6.0 and patched it to 6.1.1, re-ran the same test and the memory leak does not occur.

Anything I could check, or just report it as a bug?

From System Info within LR

Lightroom version: 6.1.1 [ 1032027 ]
License: Perpetual
Operating system: Windows 7 Enterprise Edition
Version: 6.1 [7601]
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 3.5 GHz
Built-in memory: 32220.4 MB
Real memory available to Lightroom: 32220.4 MB
Real memory used by Lightroom: 4432.2 MB (13.7%)
Virtual memory used by Lightroom: 5534.5 MB
Memory cache size: 5473.8 MB
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1200, 2) 1920x1200
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
GeForce GTX 760/PCIe/SSE2

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 355.98
Renderer: GeForce GTX 760/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler

Application folder: C:\Program Files\Adobe\Adobe Lightroom
Library Path: O:\Digital Pics\Digital Pics-2-2.lrcat
Settings Folder: C:\Users\stu\AppData\Roaming\Adobe\Lightroom

Installed Plugins:
1) Behance
2) Canon Tether Plugin
3) Facebook
4) Flickr
5) HDR Efex Pro 2
6) Leica Tether Plugin
7) LRHaze
8) Nikon Tether Plugin

Config.lua flags: None

Adapter #1: Vendor : 10de
Device : 1187
Subsystem : 27653842
Revision : a1
Video Memory : 1990
AudioDeviceIOBlockSize: 1024
AudioDeviceName: Speakers (High Definition Audio Device)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: Uninitialized
Direct2DEnabled: false
GPUDevice: not available
OGLEnabled: true
Photo of Stuart Turgis

Stuart Turgis

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Stuart Turgis

Stuart Turgis

  • 4 Posts
  • 0 Reply Likes
Interestingly, in v.6.1.1, copying metadata across 120K images, also causes a memory leak. But also the file handle total is just shy of 300k.

So perhaps the memory leak is related to file handles. I've not tried with 6.2.

Secondly, perhaps less efficiently, I selected all images and then pasted the metadata, as opposed to leaving LR to give me the option. Could this cause the memory leak issue ?
Photo of Stuart Turgis

Stuart Turgis

  • 4 Posts
  • 0 Reply Likes
one further addition. After finishing, the memory halves from 30GB to 15GB, and the number of open files from 300K drops to 3K. 10 minutes later and the memory has not reduced back down to the previous level of 4GB.
Photo of Stuart Turgis

Stuart Turgis

  • 4 Posts
  • 0 Reply Likes
HI

Upgraded to 6.2.1. and the memory leak for previews is fixed thank you. Will try metadata copying and see if that is fixed or not.