Lightroom 2015.9: Shifts images when looking at actual pixels

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
  • (Edited)
I just pulled apart my tripod head and was running a series of test shots to see if it was still "drifting" over time before attempting a complex panorama where each panel will be the median filter of a stack of images.

I locked this sucker down good and shot a series of images (mirror up, 3s delay to minimize vibration, electronic remote). Took 3 sets of 4 images 20 minutes apart of a building with very crisp details 1000' feet away with a very sharp 105mm lens. Nikon D800, RAW mode so lots of pixels to play with.

In Lightroom, I compared the images in Develop by selecting the four images and pressing Enter to view full screen, then space bar to see actual pixels. Using the right arrow key to move between images _DSC6490, 91, and 92 were exact matches. But 93 jumped a LOT (11 pixels horizontally, 52 pixels vertically on my Thunderbolt monitor). Weird. Then I got suspicious. There's no way the head moved that much on the last shot when all 4 were taken within 16 seconds.  When I went through the images using the left arrow, the jump happened between 91 and 90, which were previously identical.

Switched Lightroom into single display mode (Full) and tried again on the MacBook Pro's Retina display. Similar jumps (49 pixels horizontally, 39 pixels vertically).

I brought those same 4 images into photoshop as layers and toggled between them. Exact pixel matches.

Good news: no tripod drift. Bad news: Lightroom bug.
Photo of Kevin Tureski

Kevin Tureski

  • 4 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3833 Posts
  • 724 Reply Likes
Kevin,

I am unable to duplicate your results on either an external monitor (27 inch Mac monitor 2560x1440) or on the Retina display. 

What is your OS version?
Photo of Kevin Tureski

Kevin Tureski

  • 4 Posts
  • 2 Reply Likes
Thanks for the quick followup. Here's my system info but see below for an updated explanation.

OS X El Capitan Version 10.11.6
MacBook Pro (Retina, Mid 2012)
2.7 GHz Intel Core i7
16 GB 1600 MHz DDR3
NVIDIA GeForce GT 650M 1024 MB

I tried with another set of images (determined to be pixel accurate by toggling between layers in Photoshop) and here is what's going on:

  • If you right arrow through a set of images when looking at actual pixels, and none of those images have been zoomed into with a mouse click, they will register correctly
  • If however, you have zoomed into any image with a mouse click, Lightroom saves that point so that when you march through that same sequence of images when zoomed in, they will jump around to the area previously selected for that image.

I can see why some users would want the "save where I zoomed into" behaviour but there is also a case for "don't save it" -- which I admit is not at all urgent since there is a workaround: import into Photoshop as layers and toggle to compare.

Feel free to downgrade this from a bug to a quirk that irritates some :-)