Lightroom 2015.5: Freezes on Mac, "not responding", requires reboot

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
Latest version of Lightroom (CC 2015.5) has a new bug.  It frequently freezes on Mac, "not responding", have to force quit.  This virtually always happens if I leave LR and do work on a different app for a while.  It frequently happens while working in LR and I get permanent spinning wheel.  On average I can work 30 minutes before it freezes, but still this is very disruptive.

It happens only with the latest version of LR.  Prior version did not have this problem in my experience. 
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes

Posted 2 years ago

  • 2
Photo of Peter Vogel

Peter Vogel

  • 63 Posts
  • 35 Reply Likes
I have exactly the same problem on Mac!

As soon as LR is in the background for a while, chances are high, that the app will not respond anymore. Two days ago, I even had the problem, that the Finder on my Mac would come to a crawl and I checked in activity monitor what the problem was and it was LR hanging and freezing everything. After killing LR, the finder was responding normal again. It really is a pain the the whatever to work like that!

The damn program hangs on import all the time and has to be killed, it hangs when it is in the background for a while and has to be killed and Adobe has had more than two weeks to come up with a fix, but it seems, that they could care less!

If there was an alternative to Lightroom and Photoshop, I for sure would have switched by now!
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1452 Posts
  • 454 Reply Likes
Did you mean Lr 2015.6 that you experienced the issue?
Photo of Peter Vogel

Peter Vogel

  • 63 Posts
  • 35 Reply Likes
Yes, LR 6.6 has these problems. With LR 6.5, I did not have the importing issue and not the hanging issue, when it was in the background.

For me, it would be a solution right now to just be able to downgrade to LR 6.5 again. 
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
YES!   Sorry, I just checked.   It is only on the most recent update that I am having this problem and it is 2015.6.    Have you heard of many others having this problem?   Is this being investigated?  It's very important.  Thanks!

BTW, please get this feedback system fixed so that it works in Safari on a Mac.  I always have to open a different browser ...  
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
Views yes but try adding a comment. The login process to comment does not work in Safari on Mac, at least my Mac. I have had this problem before.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3833 Posts
  • 724 Reply Likes
Comment added in Safari on El Capitan....
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
I login using email and password, not Facebook etc. Also I login on the feedback page. Does that match your experience? What page do you login on? I have had this same login problem for months where in Safari it tells me I am logged in in a separate popup window but the fact that I am logged in does not get back to the feedback page. This process does work in Firefox on Mac and in Safari on iPad but not in Safari on Mac. BTW I always have latest version of everything.
Thanks
Art
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
I did not mean to distract from the problem that initiated this thread: Lightroom freezing, requiring reboot, frequently.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4309 Posts
  • 1571 Reply Likes
(I also always use Safari on Mac for posting, and log in using my Apple ID. It's specific to your computer, sorry Art. Try clearing all Adobe.com cookies.)
Photo of Peter Vogel

Peter Vogel

  • 63 Posts
  • 35 Reply Likes
I had enough of that crap and wanted to downgrade to LR 6.5.1, since I have an important job on Thursday and can not afford to have LR freeze when I want to import files right in front of the very eyes of my client.
Well, I started the installer of an older version of LR 6 and it wanted me to login with my Adobe ID before installation. So I did that and after login, the damn thing just crashed to desktop! I tried to launch the installer three times more and every time it crashed to desktop even before any window would appear. "Adobe application manager crashed" would you like to send a report - no thanks, that will not change a damn thing anyway, because the Adobe people are on vacation!

I am really totally fed up with the fact, that Adobe put out a version .6 with major bugs and within almost three weeks, was not able to give us a fix or even just post an installer file, that would at least downgrade 6.6 to 6.5 again for people who are trying to make money with photography!
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
I use Capture One to tether working with clients. $15 per month. Edit in LR-PS.
Photo of Peter Vogel

Peter Vogel

  • 63 Posts
  • 35 Reply Likes
Well, LR worked just fine for me since version 1, so I don't see the point in switching to a third program and using three programs to do the job, if it works with two of them.
The point I am trying to make is, that a company like Adobe should be able to fix a major bug in a program, that was introduced with a version .6 update and was not there in version .5! Especially if it keeps you from doing the most important thing, importing images into the program.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Hi Peter, could you install today's update: http://blogs.adobe.com/lightroomjournal/2016/07/lightroom-cc-2015-6-1-now-available.html and let us know how it's working for you? It has a number of fixes which should improve performance and stability.
Photo of Peter Vogel

Peter Vogel

  • 63 Posts
  • 35 Reply Likes
Hi Jeffrey,

I already installed the update and tested the import function with CF-cards and an iPhone and so far it all works as it should!
I will test more tomorrow, including letting LR sit in the background for a while, etc., basically the things that were broken for me in 6.6.

Cheers

Peter
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Thanks for the update, Peter. Let us know if you still have any issues.
Photo of Niamh Katee

Niamh Katee

  • 2 Posts
  • 0 Reply Likes
I use Capture One to tether working with clients. $15 per month. Edit in LR-PS.
http://www.immaculateassignments.co.uk/
Photo of markinho

markinho

  • 21 Posts
  • 2 Reply Likes
As soon as LR is in the background for a while, chances are high, that the app will not respond anymore.
Hello,

I am having the exact same problem here with V6.6, so annoying !
I just put the new update and I cross my fingers :-)
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
Yes i tried that twice, second time during the screen share with Adibe tech support. Got error codes trying to run the patch.
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
Something catastrophic happened to software development at Adobe iver the past year. Change in personnel, change in locations, something. Something happened. Maybe they changed the archecture going to CC and that made it error prone. Something happened.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1452 Posts
  • 454 Reply Likes
Have you tried to uninstall Lr and reinstall from scratch? (after uninstall, download and install the Lr CC Lr CC 2015/6.0 from the above url. After that download and install the Lr CC 2015.6.1/6.6.1 patch on top of the base Lr CC Lr CC 2015/6.0 install.

If that still does not work, try the big hammer https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html.
Photo of Art M.

Art M.

  • 78 Posts
  • 15 Reply Likes
If I uninstall 2015.6 can I install 2015.5? That could be a safe harbor for me for a while.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1452 Posts
  • 454 Reply Likes
Yes. 2015.5.1 is better.