Photoshop Elements: Lost and cut in half pictures (missing pictures in Photoshop Album Starter Edition)

  • 2
  • Problem
  • Updated 7 years ago
  • (Edited)
My pictures on PS Album Starter 2 all have a small red box on them that is cut in half. i cannot pull them up or move them even though they are still visible. i wanted to transfer them to a free download of element 9 but they dont show up. Can anyone help?
Photo of Mark Everett

Mark Everett

  • 3 Posts
  • 0 Reply Likes
  • sad, confused ,fustrated

Posted 7 years ago

  • 2
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 111 Reply Likes
The small red box icon indicates that the image has become disconnected. The Photoshop Album/Elements catalog is a database that includes information about your image files, but not the images themselves. One of the pieces of information the catalog keeps is the file path to the image. If that information is outdated, the image becomes disconnected in the catalog. This can happen if the file has been moved to another folder, renamed, or deleted. The image can be reconnected to its current location or name, or restored from a backup. That visible bit you can see is a cached thumbnail, not the full resolution image.

-Brett
Photo of Mark Everett

Mark Everett

  • 3 Posts
  • 0 Reply Likes
I'm still lost!!! How do I get them back Everything i try doesn't work!!!!
Photo of Foster Brereton

Foster Brereton, Programmer

  • 41 Posts
  • 14 Reply Likes
Perhaps this link can help you out?:

Reconnect missing files in Photoshop Elements
Photo of Mark Everett

Mark Everett

  • 3 Posts
  • 0 Reply Likes
Foster - Hi - My images with the broken box are on the pictures in PS Album 2 - when i tried to transfer to the Organizer on Element 9 all i got was a box with a blank and a ? mark. That's my problem, i cant get them out of PS 2 or i don't know where they went. It just showed up like that recently. didn't know that PS 2 was obselete. I myself did not transfer them or delete them myself - at least not intentionaly. Not computer literate unfortunately
Photo of Foster Brereton

Foster Brereton, Programmer

  • 41 Posts
  • 14 Reply Likes
Hi Mark - so unfortunately it sounds like PS Album 2 cannot find the images you originally put into it and reconnecting them is proving difficult. Perhaps you filled in the album with pictures from your camera (instead of copying them to your hard drive first) and then disconnected the camera? There could countless other ways PS Album 2 got disconnected from the images you were organizing with it.

At any rate the best solution at this point seems to be to find the images outside of both PS Album 2 and Elements, and import them from that location into Elements. Do they exist on a hard drive, camera, or other external storage space? If so I'd go "right to the source" and try to import them from there into Elements. I hope that helps.
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 111 Reply Likes
If Foster's link doesn't provide a solution, please review the information here.

-Brett