Lightroom: Lost almost all of my plug-ins (LR 2015.10.1)

  • 1
  • Problem
  • Updated 11 months ago
  • Solved
  • (Edited)
Today when opening Lightroom I've seem to lost almost all of my plug-ins.

The default ones like AdobeStock and Facebook are there, and jf Metadata Wrangler, but several 3rd party are missing.

Anyone run into this issue and found a solution to fix it without the need to reinstall and enable all plug-ins?

LR 2015.10.1

Thanks!
Photo of anssik

anssik

  • 123 Posts
  • 28 Reply Likes

Posted 1 year ago

  • 1
Photo of Stanley-Carl du-Pont

Stanley-Carl du-Pont

  • 44 Posts
  • 10 Reply Likes
When this happens, Lr has lost its reference to the location of the plugins.

A way to restore plugins that it no longer references correctly, is to "Add" them again by pointing to the location of the plugins. Do this by selecting "Plug-in Manager" under the "File" menu item in the Library module [just as you would when first adding a plugin].

It is recommended that before adding plugins to Lr, create a subfolder to hold all plugins. Add all plugins to this subfolder before adding them in Lr.

Placing this folder alongside the "Lightroom Settings" folder means it is always easy to locate on a hard drive and makes the process of reinstalling/re-adding "lost" plugins easier.
Photo of anssik

anssik

  • 123 Posts
  • 28 Reply Likes
Thanks. I did just that, re-added my plug-ins. It's a bit frustrating with 20+ of them, how to prevent it from happening?

The one 3rd party not removed seemed to forgot on Downloads folder so you're probably correct that LR lost its reference to the location of the plug-ins as I keep my plug-ins on the same external SSD drive that my LR Catalog, Smart Previews and Previews are.
Photo of anssik

anssik

  • 123 Posts
  • 28 Reply Likes
Today it happened again – plugins lost. I did fire up Lightroom before I'd had mounted my Lightroom Catalog external SSD to my iMac. Lightroom informed the default catalog can't be found so I chose quit, mounted the external SSD and reopened LR. Can this affect why plugins installs sometimes are lost?

I'm keeping all LR plugins in the same external SSD as the LR Catalog files (together with Smart Previews and Previews) as I've figured this to be the best practice using LR between multiple computers (my iMac and to MacBook Pros).
Photo of john beardsworth

john beardsworth

  • 1020 Posts
  • 229 Reply Likes
Is it just your plugins that are lost, or are all preferences being reset?

It sounds like the latter, and you need to ask why your preferences keep getting reset. So how have you set Preferences / Presets / Store presets with this catalog ?