LIGHTROOM - Localization problems

  • 1
  • Question
  • Updated 3 years ago
  • (Edited)
Hi

I seem to have a localization issue with Lightroom CC and I am unsure if it is to be considered a bug or a preference I have missed.. I am on OSX El Capitan, and my system is set to English, but with Swedish region.

I have two problems within Lightroom:
1. Collections (and potentially other things I haven't noticed) are sorted wrong, when sorted alphabetically. It is sorting the swedish characters ÅÄÖ as AAO, when they should be sorted last, in that order (XYZÅÄÖ). Sounds quite minor, but it is really awkward when I naturally look for something like "Åbrolla" far down in my collection list, and it turns out it's up in the top.

2. The date is displayed with what I assume is US format (08/08/14), when it should be (14/08/08), that is YYMMDD when written like that.

Can I fix this somehow? Sounds a bit minor, but it's really awkward. ;)
Photo of Kenny Lövrin

Kenny Lövrin

  • 7 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Iouri Tchernoousko

Iouri Tchernoousko, Employee

  • 73 Posts
  • 16 Reply Likes
Kenny, thank you for the observation. I forwarded your comment to the LR localization team. They will need to check what globalization libraries they are using, or advise you what drives the display of the sorting order and date format in LR. We will post a reply here regardless.

Best regards,
Iouri Tchernoousko, PS globalization, Adobe in San Jose
Photo of Kenny Lövrin

Kenny Lövrin

  • 7 Posts
  • 0 Reply Likes
Here's a screenshot of my settings.. However, now that I look at it, I see that the short date is the same format in Lightroom as it is in my preferences (so based on that I assume that Lightroom is doing the right thing with regard to the date format).

The collections are sorted wrong though

Photo of Iouri Tchernoousko

Iouri Tchernoousko, Employee

  • 73 Posts
  • 16 Reply Likes
Yes, noticed the prefs information in your first post, but thank you for the screenshot. My first guess is that the date format in LR mirrors your system's. Will look into it, especially the sorting, however.

Iouri
Photo of Rose Lu

Rose Lu, Employee

  • 9 Posts
  • 1 Reply Like
Hi Kenny and Iouri,  I am working with Lightroom IQE team to verify this issue and will update the result with you shortly.

Rose Lu, IPM of Lightroom
Photo of Tushar Rajvanshi

Tushar Rajvanshi, Employee

  • 2 Posts
  • 1 Reply Like
Hi Kenny,

Thanks for the observation. Going by your last comment, I guess you have already discovered the date format can be altered by changing the date format.
The List sort order is also decided based on a system setting “List Sort Order” in the Mac OS. The setting is available under System Preferences -> Language and Region->List Sort Order. There are 3 sorting orders available for Swedish.

1. Swedish (Standard Sort Order)
2. Swedish (Reformed Sort Order)
3. Universal


The first 2 settings are specific to Swedish and would sort in the order – XYZÅÄÖ while ‘Universal’ would sort in the order - ÅÄÖXYZ.

Looking at the screenshot in your last comment, the system is set to Universal and that’s why the list is sorted as ÅÄÖXYZ. If you examine, you would find the OSX sorting would be the same, Lr only mimics that behavior.

Hence, please switch to the one of the two Swedish specific sort orders to get the desired sorting.

Below screenshots showcase the behavior with different sort orders.

1. Swedish (Standard Sort Order)



2. Swedish (Reformed Sort Order)



3. Universal



Regards,
Tushar Rajvanshi, IQE, Adobe Photoshop Lightroom
Photo of Kenny Lövrin

Kenny Lövrin

  • 7 Posts
  • 0 Reply Likes
Hi

Thanks for your reply! I suspected that changing the sort order could fix the problem, but I wanted to wait for your input before I started changing things as I have never experienced this sorting issue in any other application.

However, now that I read your response, I tried creating the folders in Finder, and of course it sorts it like Lightroom does.

So first of all, I'm sorry to bother with this issue, I could just have tried changing the sort order and there would have been no issue. However I have never noticed this issue before (which is strange in itself), so an honest mistake I guess. :)

Anyway, thanks for the help, problem solved then. :)

Kenny