Lightroom Classic: Load library failed with error 1114: a dynamic linc library(DLL) initialation routine failed

  • 2
  • Question
  • Updated 1 year ago
  • (Edited)
After I upgraded to Lightroom Classic I get the above message. My laptop has two graphics cards. One on board and one installed. I run the laptop with a second screen for editing. Graphics drivers uploaded to latest. If I switch one of the two of, Lightroom opens, but on the laptop screen only. If I switch them both on, Lightroom gets the above message. I have also switched the use of the graphics card of in Lightroom. This is frustrating because in the previous version everything worked. Please help.
Photo of Deon Coetzee

Deon Coetzee

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1490 Posts
  • 471 Reply Likes
Does the message dialog tell which DLL loading failed? Given that Lightroom opens when you switching the second (your main) screen off, there might be some issue with the graphics driver for that machine.

1. Does Lr work with both monitor on if you turned off the GPU acceleration from the Lightroom preference? See https://helpx.adobe.com/lightroom/kb/lightroom-gpu-faq.html for instructions.
2. How do you normally keeping your GPU driver up-to-date? I recommend follow the GPU FAQ and download the most recent driver directly from your graphics card manufacturer's website. And then follow the described "Perform a clean installation of your graphics card driver" procedure to do a clean driver install.
Photo of Andrew G Carey

Andrew G Carey

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic CC: Will not boot, error 1114: A dynamic link library (DLL) ini....

LoadLibrary failed with error 1114: A dynamic link library (DLL) initialization routine failed.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1490 Posts
  • 471 Reply Likes