Photoshop: Liquify Tool - black pixels after edit (macOS Mojave 10.14.0 & 10.4.2)

  • 63
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
Just updated my Mac to Mojave today.

Liquify is creating black pixels when used.

I have tried to optimize performance but I still get the same error.

I have a super fast machine, so is not a RAM error. Liquify was working normally before Mojave OS.

In the image below, I have slightly adjusted the smile of the subject.
Photo of jun

jun

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 63
Photo of Olivier MULLIE

Olivier MULLIE

  • 51 Posts
  • 20 Reply Likes
Mac OS Mojave 10.14.1 is out, please update your Mac and the problem is forgotten...
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2368 Reply Likes
This issue is back with the macOS 10.14.2 update. See details and workarounds here: Black artifacts on image after using the Liquify filter

We're working with Apple to address this issue: Photoshop: Liquify bug is back in Mojave 10.14.2
(Edited)
Photo of Julius Batulevicius

Julius Batulevicius

  • 14 Posts
  • 0 Reply Likes
I do appreciate that apple is working on it as it suppose to be, but Mojave shouldn't be let it out before they are sure it is fixed, especially on their own products is issues all over. It is first serious one which affected me and made me suffer in certain circumstances.
Thanks
Julius
Photo of Marc De Ganck

Marc De Ganck

  • 1 Post
  • 0 Reply Likes
I hope the problem will be resolved quickly. It is really annoying. All the more so that I can not go back to 10.14.1 (retailer did upgrade from 10.14.0 directly to 10.14.2)
Photo of Alejandra Reznicek

Alejandra Reznicek

  • 1 Post
  • 0 Reply Likes
Also the clone stamp is not working properly when trying to fix the pixels by hand. This is really annoying and time consuming.
Photo of Antti Kohonen

Antti Kohonen

  • 1 Post
  • 0 Reply Likes
Always the same: New features bring new bugs. Really annoying...
Photo of dogmom246

dogmom246

  • 1 Post
  • 0 Reply Likes
I have the similar problem but with blue and cyan artifacts... first time I've ever seen it but don't know the last time I used it with this OS.  It seems I can clone them out? Is that a quick fix as well? If I see them on the screen, they WILL show on a print, correct? Not like guides that can be turned on and off? It also seems to be showing a before and after liquify trail... I can match up the pixels/artifacts.