PHOTOSHOP: Linked objects "visually" delete a part of the canvas on MacOS 10.10

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
I work with a project where every layer is a linked object made of a multi-layered PSD (over 5000px).

The problem is, all of the sudden I can only see a blank space (transparent grid) in the master image, unless I embed the linked objects.

The other solution is to resize the master image.

Adobe Photoshop Version: 2014.2.2 20141204.r.310 2014/12/04:23:59:59 CL 994532 x64
Operating System: Mac OS 10.10.1
System architecture: Intel CPU Family:6, Model:58, Stepping:9 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, HyperThreading
Physical processor count: 4
Logical processor count: 8
Processor speed: 3400 MHz
Built-in memory: 32768 MB
Free memory: 23545 MB
Memory available to Photoshop: 30866 MB
Memory used by Photoshop: 91 %
3D Multitone Printing: Disabled.
Windows 2x UI: Disabled.
Highbeam: Disabled.
Image tile size: 1024K
Image cache levels: 4
Font Preview: Medium
TextComposer: Latin
Display: 1
Main Display
Display Bounds: top=0, left=0, bottom=1440, right=2560
OpenGL Drawing: Enabled.
OpenGL Allow Old GPUs: Not Detected.
OpenGL Drawing Mode: Advanced
OpenGL Allow Normal Mode: True.
OpenGL Allow Advanced Mode: True.
AIFCoreInitialized=1
AIFOGLInitialized=1
OGLContextCreated=1
NumGLGPUs=1
NumCLGPUs=1
glgpu[0].GLVersion="2.1"
glgpu[0].GLMemoryMB=2048
glgpu[0].GLName="NVIDIA GeForce GTX 680MX OpenGL Engine"
glgpu[0].GLVendor="NVIDIA Corporation"
glgpu[0].GLVendorID=4318
glgpu[0].GLRectTextureSize=16384
glgpu[0].GLRenderer="NVIDIA GeForce GTX 680MX OpenGL Engine"
glgpu[0].GLRendererID=16918308
glgpu[0].HasGLNPOTSupport=1
glgpu[0].CanCompileProgramGLSL=1
glgpu[0].GLFrameBufferOK=1
glgpu[0].glGetString[GL_SHADING_LANGUAGE_VERSION]="1.20"
glgpu[0].glGetProgramivARB[GL_FRAGMENT_PROGRAM_ARB][GL_MAX_PROGRAM_INSTRUCTIONS_ARB]=[16384]
glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_UNITS]=[8]
glgpu[0].glGetIntegerv[GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS]=[16]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS]=[16]
glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_IMAGE_UNITS]=[16]
glgpu[0].glGetIntegerv[GL_MAX_DRAW_BUFFERS]=[8]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_UNIFORM_COMPONENTS]=[4096]
glgpu[0].glGetIntegerv[GL_MAX_FRAGMENT_UNIFORM_COMPONENTS]=[2048]
glgpu[0].glGetIntegerv[GL_MAX_VARYING_FLOATS]=[124]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_ATTRIBS]=[16]
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_PROGRAM]=1
glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_PROGRAM]=1
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_SHADER]=1
glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_SHADER]=1
glgpu[0].extension[AIF::OGL::GL_EXT_FRAMEBUFFER_OBJECT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_RECTANGLE]=1
glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_FLOAT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_OCCLUSION_QUERY]=1
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_BUFFER_OBJECT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_SHADER_TEXTURE_LOD]=1
clgpu[0].CLPlatformVersion="1.2 (Sep 20 2014 22:01:02)"
clgpu[0].CLDeviceVersion="1.2 "
clgpu[0].CLMemoryMB=2048
clgpu[0].CLName="GeForce GTX 680MX"
clgpu[0].CLVendor="NVIDIA"
clgpu[0].CLVendorID=16918272
clgpu[0].CLDriverVersion="10.0.43 310.41.05f01"
clgpu[0].CUDASupported=0
clgpu[0].CLBandwidth=3.77751e+10
clgpu[0].CLCompute=96.4631
Photo of Pawel

Pawel

  • 15 Posts
  • 2 Reply Likes
  • frustrated, sad

Posted 4 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
Do you have a screen shot of what you're seeing?
Photo of Pawel

Pawel

  • 15 Posts
  • 2 Reply Likes
Sure:


I think the blank area is somewhat random and it doesn't relate to layer edges.

The background you see is a linked layer and it is supposed to be "full".

I'm forced to change my workflow because of that and I don't get the benefit of otherwise excellent feature...
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
"The other solution is to resize the master image."

Are you just resizing the document window size (by dragging a corner of the image) or zooming in and out? Or are you changing the actual number of pixels in the document using a command like Edit>Image Size...
Photo of Pawel

Pawel

  • 15 Posts
  • 2 Reply Likes
I changed the image size in Edit > Image Size. The original is 7500px wide, I changed it to 7400px and it magically "refreshed" the layers.

The blank space was behaving as if it was a part of the image, so resizing the document window was acting normally.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
That sounds like a video driver bug, and you're on MacOS 10.10 with an NVidia chipset - which has several known driver bugs.

Apple is aware of the video driver bugs introduced in MacOS 10.10 and working on solutions.
Photo of Pawel

Pawel

  • 15 Posts
  • 2 Reply Likes
Thank you for the interest. I experience a lot of minor issues related to video card while using Photoshop, but you can feel they are obvious glitches - scrambled image, shifted blocks, etc. This particular issue seems to be video independent as the blank space is consistent with the image on every zoom level.. but maybe it's another kind of video driver bug, as you say.. Yet turning off the GPU settings and switching into software rendering presents the same issues..