Photoshop CC Line 455: "window" doesn't have a constructor? Help me fix, please!

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
After several re-installs with CC app failing to update. I've encoutnered an error in Photoshop that's driving me crazy. I've searched all the forums and other topics, I've searched google... and the only thread that had a similar problem to mine had no replies.
Here's the thing: I'm trying to import (once again!) my presets, brushes and what-so-ever. I get an error message:
Line: 455 - Reference Error : Window does not have a constructor.
I was working just fine ntil the other day. What may have caused it and how can I make it work?

Thanks in advance.
Photo of Gabriela Nascimento

Gabriela Nascimento

  • 3 Posts
  • 0 Reply Likes
  • frustrated. A lot.

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Could mean that the scripting support plugin isn't loading (damaged, removed, or failed to update), or it could mean that someone mistakenly copied scripts or plugins from a previous version of Photoshop.
Photo of Gabriela Nascimento

Gabriela Nascimento

  • 3 Posts
  • 0 Reply Likes
Hello, Chris, thanks for the quick reply.

I've seen you saying this before in other threads, and as I didn't find any satisfatory reply to how to fix the error, I decided to open up this one. Only saying that files where moved or deleted, or pug-ins aren't loading won't really help me here.

If they aren't loading, or somehow they were deleted by the tool cleaner kit (which I didn't use this time. I had a problem with the Adobe Creative Cloud App fordesktop updating itself - as I had the same issues with the last 4 updates, had to run the cleaner, and I was still able to import pressets, but this time, I managed to update the CC app properly, and suddenly this comes up.

Any idea how to fix this, is this issue related to the CC App for desktop in anyway? ( I had a similar problem with CS5 and 6 before I even had the CC app for desktop, and I was never able to fix this, Importing pressets was doing fine on PS CC until yesterday when that happened.)
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Since we don't know exactly what may have been moved or deleted, we can't provide more specific. You (should) know what was done on your system.

This could be caused by an updater or installer error.
And the best way to solve it is to clean any any plugins or presets you copied, and then uninstall and reinstall Photoshop.
Photo of Gabriela Nascimento

Gabriela Nascimento

  • 3 Posts
  • 0 Reply Likes
Alright, I'm facing a problem even on unistall, I'll run the tool kit and install everything all over again. Thanks.
Photo of PECourtejoie

PECourtejoie, Champion

  • 768 Posts
  • 279 Reply Likes
So, the issue happens only when you import presets, etc? Did you import them in parts, to see which one causes an issue?