Ligthroom 4.3 : Book module don't work

  • 2
  • Problem
  • Updated 6 years ago
Hello,
I had Lightroom 4.2 and, when starting it, it suggested me to install LR 4.3.

I do that whith success but the book module no longer work -> error message "unknown C++ exception". And the test book I made has desappeared.

No way to solve that. So I re-install LR 4.2 and it is now quite good. Il found back my test book and the book module works correctly. Note that my PC works with Windows Vista.

I am very surprise you deliver a version which is not operational !
Can-you help me ou must I wait for LR4.4 ?

Daniel Pigeon
pigeond@wanadoo.fr
Photo of Daniel PIGEON

Daniel PIGEON

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 2
Photo of LR List001

LR List001

  • 7 Posts
  • 0 Reply Likes
The book module 4.3 works fine for me, upgrading from 4.2. Windows 7-64.
Photo of Jingshu Li

Jingshu Li, Bridge Quality Engineer

  • 13 Posts
  • 1 Reply Like
I cannot reproduce the issue in Windows Vista.
Actually I've seen the error message only once in LR 4.2, but after I upgrade to LR 4.3 it works well. Even though I restore the Windows Vista OS and install LR 4.2 again, I cannot reproduce.

What time do you see the error message after upgrated to LR 4.3? Just launch LR4.3 or switch to Book module?
Could you please try to upgrade to LR 4.3 again? Please backup your catalog before the upgrading.

Thanks,
Jingshu
LR QE
Photo of Daniel PIGEON

Daniel PIGEON

  • 2 Posts
  • 0 Reply Likes
I followed your recommandandation and made a new installation :
. I uninstalled LR4.2 and CS6
. I re-installed LR4.1 (with the CD) then LR 4.2 update
. I re-installed CS6 and its updates
. I tried them -> Ok
. so I reloaded LR 4.3 (I perhaps had a corrupted version the first time ?)
. I re-installed LR 4.3

And now it's Ok. All seems to work correctly.

Many thanks for your help and your time.
Best regards