Lightroom: Watermark editor font issues

  • 2
  • Problem
  • Updated 3 years ago
  • Acknowledged
Watermark editor font issue #1:

The lack of a scrollbar on the fontlist in the Watermark editor of Lightroom, makes experimenting with different fonts very slow.
And I do like to experiment with fonts.
Since the fontlist in the Identity Plate editor has scrollbars, I do not see any reason why the fontlist in the Watermark editor should not have one.

Watermark editor font issue #2:
I have several fonts that I can only find as .OTF files, and would like to use said fonts in the Watermark editor.
The problem is, even if I physically install the .OTF into the system, the Watermark editor fontlist REFUSES to see them.

The ONLY workaround for this so far is to make the Watermarks in Photoshop and use a graphic as a Watermark.
This however is not always ideal or wanted.
Photoshop on the other hand, sees ALL my .OTF fonts...

I for one would appreciate a fix for these issues, anyone else?
Photo of My Buisness

My Buisness

  • 10 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 2
Photo of Julie Kmoch

Julie Kmoch, Sr. Development Manager

  • 92 Posts
  • 31 Reply Likes
Yes, the inability to see the OpenType fonts on Windows is a known limitation based on some of the lower level graphics routines we're using. It bugs us too and we do hope to change that at some point, but it's not a trivial change.
Photo of My Buisness

My Buisness

  • 10 Posts
  • 0 Reply Likes
Fair enough, it's not a workflow-stopping issue, more like an extra bell to the bells 'n' whistles.

What about the scrollbar issue?
Photo of Joshua Vensel

Joshua Vensel

  • 7 Posts
  • 0 Reply Likes
Glad to hear it's being addressed.
Photo of MartinL


  • 4 Posts
  • 0 Reply Likes
So, 4 years and 2 versions later and.....