Lightroom: Unable to change main photo in image display area with the mouse

  • 1
  • Problem
  • Updated 6 years ago
Using Adobe Lightroom 4.1 I am unable to change the photo that is displayed in the main image display area when I click a photo in the filmstrip with the mouse. This occurs in both Library mode and Develop mode.

When I click a photo in the filmstrip the photo becomes selected in the filmstrip (light gray border) but the main image does not change it remains the same. If instead of using the mouse to click I just move with the left and right arrow keys on the keyboard then the main image changes.

I am using Windows 7 x64.

I have been using this version of Lightroom on this computer for a number of months without this issue so I am not what changed to cause this change in behavior.
Photo of Joe Solano

Joe Solano

  • 7 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 333 Reply Likes
Mouse driver would be an obvious place to check.

Which mouse are you using? Are you using a tablet?
Multiple monitor or single set up?
Photo of Joe Solano

Joe Solano

  • 7 Posts
  • 0 Reply Likes
I was having the issue on my Dell Laptop, a Precision M6600 with just the internal keyboard, touchpad and LCD. Yesterday I hibernated the computer and then woke it up in my docking station which has a Logitech keyboard and mouse and 3 Dell monitors, after doing this the problem corrected itself. Not only did it start working correctly with the Logitech mouse but when I hibernated the computer again and woke it up just by itself the internal trackpad started working again. Guess it was just a ghost in the machine.

Thanks
Joe