Lightroom Re-Publish not triggered by Edit-In-Original (5.4)

  • 4
  • Problem
  • Updated 4 years ago
  • Acknowledged
I don't see this documented anywhere, and to me it's a bug.

If I have a TIFF (or JPG I guess) in Lightroom, and do an EDIT IN photoshop, using original, the image will be updated, but that image will not be marked for republish in any publishing collections in which it exists.

Lightroom should check to see if the image has changed and mark it so. I realize there are some timing and synchronization issues, but the current process (which leaves it always unmarked) means published collections are falling out of date.

Note it "notices" that a new preview is needed, so it should be able to also notice that "hey, and if I need a new preview and it's published, must need to republish also".

I've tried this with a couple of plugins, so I assume it is systemic and not plugin specific, but have not looked at the mechanics in the SDK. Am I correct this should be handled generally, not in the plugin?
Photo of Linwood Ferguson

Linwood Ferguson

  • 23 Posts
  • 17 Reply Likes

Posted 4 years ago

  • 4
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1356 Posts
  • 310 Reply Likes
I can duplicate what you are seeing here. I have reported it.
Photo of Chapman Shoop

Chapman Shoop

  • 1 Post
  • 0 Reply Likes

Wrote a publish service and got a report from a client that photos they were editing in photoshop weren't re-publishing.

Ran through the same steps (publish photo, "edit original" in photoshop cc 2014, save edits in photoshop, image is updated in lightroom but the publish section does not recognize that it needs to be re-published) and was able to reproduce.

ETA on fix?
Photo of Robin Peeples

Robin Peeples

  • 1 Post
  • 0 Reply Likes
+1. Is this something you guys are looking into? Thanks so much!