Lightroom import from D7000 hangs randomly

  • 1
  • Problem
  • Updated 7 years ago
I've been using Lightroom since I got my D7000 a few months ago. I'm having a problem where the import process hangs at a random point in any given import session. By "hang" I mean the progress bar at the top left of the Lightroom UI stops moving and no new photos are imported. The CPU is idle and there is no USB traffic to the camera. If I cancel the import operation I can use other Lightroom features, but the "Import..." button remains greyed out until I restart Lightroom.

I can't determine a pattern for when this happens, but if I import more than about 10 photos at a time the problem is 100% reproducible. I can work around the problem by copying all photos to a disk or network share and importing them from there, but that's annoying. This sure looks like a deadlock on whatever thread handles IO, or a dropped event causing the import process to stall.

Let me know if there's any additional information I can provide to help get this issue resolved.

Details:
Lightroom 3.4.1
Windows 7 SP1 64-bit
Nikon D7000
Photo of Dustin Byford

Dustin Byford

  • 3 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Dustin Byford

Dustin Byford

  • 3 Posts
  • 0 Reply Likes
One thing I can say about when the import hangs is that if it hangs on a specific picture, it will get hung on the same picture if I import everything again. It's like some attribute of a percentage of the pictures on my camera cause this issue.
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 104 Reply Likes
Does the same problem happen when you import via a card reader, as opposed to direct connection to the camera?
Photo of Dustin Byford

Dustin Byford

  • 3 Posts
  • 0 Reply Likes
I'll give it a try tonight and let you know.