Lightroom: catalog "appears to be damaged" after move from XP to 64 bit Windows 7

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
I have copied my old catalog from XP (32 bit) to Windows 7 (64 bit). Whether "opening" from Lightroom (3.6 or 4) or double-clicking on it, I get errors saying it could not be opened due to an unknown error or that it appears to be damaged. The same files works fine with Lightroom 3.6 on XP. Backup catalogs fail in the same way.

Any ideas how I can resurrect the old catalog used with thousands of pictures? Thanks!
Photo of Randall Ricklefs

Randall Ricklefs

  • 1 Post
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Randall, I'll send you a private message to obtain the catalog.

Becky
Photo of Gary Wallace

Gary Wallace

  • 2 Posts
  • 0 Reply Likes
I have a similar problem.

I have an external HD (with XP produced LR 3.4 catalog That works on XP Laptop) but am having diffaculty with my new Window 7 64 bit upgraded to 3.6 install of Lightroom on new computer.

How do i do this with out hurting the HD Catalog?
Should I go ahead and upgrade to LR 4 before or after?
Any help/suggestions?
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Gary, it would be best, I think, to get your catalog working on your Win7 machine with Lightroom 3.6, before you upgrade to 4.0. I just want to make sure the number of changing items is minimized at each step.

Can you be more specific about the difficulty you see opening the catalog on Win7?

Thanks,
Becky
Photo of Gary Wallace

Gary Wallace

  • 2 Posts
  • 0 Reply Likes
I think I have it solved. The Photos and catalog are on an external HD that is a usb 3 unit. I had been running it on the old XP as a usb 3 unit. The issue I have is that the new Win7 computer will not boot with the external HD connected to a usb 3 port ( or even in a usb 2 port. I talked with the manufacture of my new computer and they think it may be an issue with the external HD.. However the info is compatible with my new install LR 3.6 install on my new computer and since it is just a boot up problem I can work around it.

Thanks for your response. i do hope to get the LR 4 after I have had a chance to get familiar with the Win 7 OS.
Photo of Romas Derman

Romas Derman

  • 1 Post
  • 0 Reply Likes
hi! same problem, but cant resolve that using your advice.