Lightroom and CS5 integration problem when files are stored on a NAS

  • 1
  • Problem
  • Updated 6 years ago
I found an issue on my Mac (Lion but was there in Snow Leopard as well) using LR3, CS5, and a NAS.

The following steps can reproduce the problem with 100% reliability. Others have confirmed this behavior (Note that everything works fine if the file is stored locally and NOT on a NAS).

1) Select a RAW file in LR on a NAS that has no corresponding Tiff file (i.e. has not been edited in CS5 yet) and select "Edit in Adobe Photoshop CS5". Edit then Close (say yes to save).
2) This will result in a TIFF version called filename-edit.tif.
3) Select this new Tiff in LR and select to edit in Photoshop again.
4) Checking the finder window will verify "-edit.tif" is still listed there while it's open in CS5.
5) Return to CS5 and "save" the file (Command-S). An "Access" error message will pop up and the tiff file will disappear from the NAS as witnessed in the finder window
6) Reattempting the save command will now result in the Save-As dialog box appearing (because the file is no longer there to allow a straight save) but the original tiff filename should be loaded. If you close CS5 without saving at this point the original Tiff file will be lost along with any edits performed the first time.

Note that saving the file in step 6 and then refreshing LR will reattach the new file to LR (since it did not know it was deleted in the first place), but this is high risk as canceling the save in step 6 will result in lost data.
Photo of Ross Dillon

Ross Dillon

  • 17 Posts
  • 3 Reply Likes
  • Quite cranky

Posted 6 years ago

  • 1

Be the first to post a reply!