Lightroom: All drives now list under VOLUMES on boot drive

  • 3
  • Problem
  • Updated 1 year ago
  • Acknowledged
  • (Edited)
Lightroom issue - In the Library module, under Folders I now have Macintosh HD as the only panel. My other drives are now listed under a "tree" within Macintosh HD in the folder Volumes. What is going on?

This needs FIXING please. How to?

How do I fix this so that my other drives show up as their own panel again?

This post outlines the same issue.
http://forums.adobe.com/message/35791...
Photo of James Kachan

James Kachan

  • 65 Posts
  • 7 Reply Likes
  • annoyed

Posted 7 years ago

  • 3
Photo of john beardsworth

john beardsworth

  • 1041 Posts
  • 239 Reply Likes
Right click a folder and choose Promote Subfolders.
Photo of James Kachan

James Kachan

  • 65 Posts
  • 7 Reply Likes
First thing I tried, this doesn't fix the issue.
Photo of john beardsworth

john beardsworth

  • 1041 Posts
  • 239 Reply Likes
What about Update Folder Location?

You could try creating a new catalogue, then using File > Import as Catalog to bring in the catalogue - it can cure all sorts of ills.
Photo of James Kachan

James Kachan

  • 65 Posts
  • 7 Reply Likes
folder location doesnt fix.
i suppose importing the calalog may work. however, Im dealing with terabytes of photos, so I'm not looking forward to the idea of that.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4309 Posts
  • 1571 Reply Likes
Back up your catalog before you try this.

Now, work your way through each top level folder in turn, right-clicking and choosing Promote Subfolders. Keep doing that until all of the folders have disappeared from Lightroom's Folder panel. Hold your nerve (this is why you backed up first!!!) and restart LR, and they should reappear as proper drives again.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4309 Posts
  • 1571 Reply Likes
Just to clarify further, right-click on / and promote subfolders. Then the same again on Volumes and promote subfolders. And then again on each of the drives that should have their own volume bar. Once you restart they should reappear.
Photo of Joakim Lagercrantz

Joakim Lagercrantz

  • 1 Post
  • 0 Reply Likes
Yippie! Thanks!
Photo of James Kachan

James Kachan

  • 65 Posts
  • 7 Reply Likes
CONFIRMED: this works. Thanks Victoria.

NOTE: Right click the Root " / " Promote subfolders
then again on "Volumes"
Then QUIT out of lightroom

When you reopen the program you should have the individual drive panels back.
Photo of Sean Brecht

Sean Brecht

  • 7 Posts
  • 0 Reply Likes
sorry... I don't see Promote subfolders when I right click on volumes
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4309 Posts
  • 1571 Reply Likes
Show us a screenshot Sean.
Photo of Sean Brecht

Sean Brecht

  • 7 Posts
  • 0 Reply Likes
Photo of Sean Brecht

Sean Brecht

  • 7 Posts
  • 0 Reply Likes
I added the Photo G-DRIVE as a new folder and it is appearing in volumes.  If I right click it there is no option called Promote Subfolders.  Perhaps the option has been renamed?  no longer exists?  Ideas, anyone?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4309 Posts
  • 1571 Reply Likes
Promote Subfolders only shows up on the parent folder - / in this case.

Back up your catalog.
Right-click on the / folder and choose Promote Subfolders.
Right-click on Volumes and choose Promote Subfolders. 
Do the same on Photo G-Drive if it still shows up.
Do the same on Users if it still shows up.

At some point in this process, everything will disappear from the Folders panel. Restart LR and it should all come back.
Photo of Sean Brecht

Sean Brecht

  • 7 Posts
  • 0 Reply Likes
I swear that I Promote Subfolders is not showing up as an option on the / parent folder
Photo of Sean Brecht

Sean Brecht

  • 7 Posts
  • 0 Reply Likes
Photo of Sean Brecht

Sean Brecht

  • 7 Posts
  • 0 Reply Likes
these are the options which appear when right-clicking on the parent folder /
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4309 Posts
  • 1571 Reply Likes
It got renamed Hide This Parent in later versions.
Photo of Sean Brecht

Sean Brecht

  • 7 Posts
  • 0 Reply Likes
Got it!  it worked.  Thank you so very much!!!!!
Photo of marcos souza

marcos souza

  • 11 Posts
  • 1 Reply Like
Volumes do not appear in the left pane, on library, as volumes but as folders. This problem started on LR3 following with LR4.
Someone else has this problem? Solutions?

This reply was created from a merged topic originally titled
LIGHTROOM: Volumes appear like folders, not like volumes.
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
See Victoria's solution above.

NOTE: In Lightroom 4 the "Promote Subfolders" command has been rebadged to "Hide This Parent".
Photo of marcos souza

marcos souza

  • 11 Posts
  • 1 Reply Like
Thank you Victoria, but, I don't know what to do now:

An internal error has occurred!

Database "/Users/issa2/Pictures/Lightroom/Catalogos/Pessoal-LR4/Pessoal-LR4.lrcat": columns rootFolder, pathFromRoot are not unique
Statement: UPDATE AgLibraryFolder SET rootFolder = ?,pathFromRoot = ? WHERE id_local = ?;
Photo of marcos souza

marcos souza

  • 11 Posts
  • 1 Reply Like
I got! There was a drive that appears two times, deleted one and it worked!
Thank you Victoria and Dorin!