Lightroom 5 Import creates 'phantom' folders.

  • 1
  • Problem
  • Updated 5 years ago
Apparently a database problem but passes a Lr integrity test ok.

For example, when I import photos to "C:\users\Wes\Wes Photo Files\2013\Canada & USA",
Lightroom CREATES a 'phantom' folder 'C:\users\Wes\Wes Photo Files\Canada & USA' in the list of Folders and adds the photos to this non-existent Folder!

See full details at http://forums.adobe.com/thread/1275315

This has happened several times - on different Destination Folders.
If you respond to this problem, please note that I have done the following:

1. double-checked my Import settings - definitely correct and "Organise' is set to 'Into One Folder'.

2. run 'Integrity Test on the Catalog' both before opening Lr and when Backing Up before closing.

3. I have tried running 'Synchronize' folder but did not proceed as it wanted to Import 818 photos! (that's the file count in the real 'Canada & USA' folder).

4. When I try 'Show Parent Folder' a database error is reported!

5. if I try to Move the files from the phantom to the real folder, it reports 'File already exists at the destination'.

6. I restored an earlier backup copy of the lrcat file but the same problem occurs.

7. I ran chkdsk on C: - no errors, and ran a Registry Cleanup - problem exists.

8. As a work-around, I can Move files from the phantom to '2013 TEMP'and then Move again from '2013 TEMP' to the desired folder '2013 Canada & USA'.

ENVIRONMENT: Lr 5.0, Windows 7 64-bit, i5 4-core, 8GB ram.
Photo of Wes Eggins

Wes Eggins

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2652 Posts
  • 340 Reply Likes
LR has two internal folder paths for the same single file-system path, with one a peer of the other's parent. This is why you get various errors when trying to make them the same folder using LR folder operations, because they really are the same folder on disk.

I have seen this happen when one of LR's internal paths has an upper-case C: and the other is lower-case c: or some other part of the path differs only in case. On a PC casing is not significant in folder paths, but in Macs, depending on how the OS is installed (or maybe how a particular disk is formatted) case is significant, so LR has to do its compares with casing in mind when on a Mac when the OS is installed with a particular option, and I think some of these compares don't get done quite right on a PC, sometimes--part of the programmer's nightmare when programming for multiple OSes.

In my case one version of the path was from using File / Import and the other version of the path was from using a drag-and-drop import. Now I always use DnD import and never File / Import.

How to fix it usually involves removing things out of the folder it doesn't want to put things in (2013\C&U) and moving them to the one that it does want to put things in (C&U not under 2013). I am using C&U as an abbreviation for Canada & USA.

So I'd try to fix it by doing this in LR -- using the numbers of photos from your screenshot in the other forum thread (818 in the C&U folder under 2013 and 3 in the version of the folder that is not under 2013 in LR):
* Drag-Move the 818 photos from the 2013\C&U folder to 2013 TEMP.
* Verify in Explorer that the folder only has the 3 photos from the other version of itself.
* Right-click Remove the seemingly empty C&U folder that is under 2013--don't delete from disk, just remove from LR's catalog.
* Right-click Show Parent Folder on the remaining C&U folder that isn't under 2013 which should add it under the 2013 in LR's view of the folders--this is where you'd want to rename the "&" to "and" if you were going to do that as suggested below.
* Drag-Move the 818 photos from 2013 TEMP to the new 2013\C&U.
--
You might be able to accomplish the same thing by doing a single right-click Update Folder Location on the 2013\C&U folder or perhaps right-click Update Folder Location on the C&U folder not under 2013 in LR, but which one fixes it, if any, depends on which one has the internal casing the way your Import sees the paths.
==
There might be something confusing about the "&" in the path, spelling that out as "and" might fix things, but only do this when there is one version of the C&U folder in LR, using the Drag-Move and Right-click Remove operations in the list, above.