Lightroom: LR5 and Mac OS 10.9 problems using 2nd monitor (remove workspace link)

  • 4
  • Problem
  • Updated 5 years ago
  • Solved
  • (Edited)
Help?

I upgraded to Mavericks today and I can't seem to figure out how to use my 2nd monitor in Lightroom 5 now.

I'm running Lightroom 5.2 with Max OS X Version 10.9.

When I click on the 2nd monitor (or do Command+fn+F11), the overlay comes up, but I'm not able to assign that screen to my 2nd monitor.

Mavericks now treats that 2nd monitor as its own desktop, but, I can't figure out how to assign that LR5 2nd monitor to a specific desktop

Note: I do have Lightroom 5 assigned to a specific workspace, which may also be a part of the issue.
Photo of Jay Pike

Jay Pike

  • 5 Posts
  • 3 Reply Likes

Posted 5 years ago

  • 4
Photo of Jay Pike

Jay Pike

  • 5 Posts
  • 3 Reply Likes
Update: Yes, this is because I had linked Lightroom to a specific workspace. When I remove that link and set the "Options" (right-click on the dock icon for Lightroom and select Options) for 'Assign To' to "None", the 2nd monitor displays fine now.

Leaving this here for others reference that may have this same issue.

jp
Photo of John Rosenfeld

John Rosenfeld

  • 7 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Lightroom: Dual monitor problem with Mavericks MacOS 10.9.


Since upgrading to Mavericks on my Mac Mini I've had a intermittent problem with my dual monitor setup. Sometimes when I select a different photo in the Library grid on my main monitor the view on the second monitor will update but a window representing the secondary monitor will pop up on the main monitor with the previous photo, as though I had disconnected the second monitor. If I shut the window the view on the secondary display also disappears and I have to click the second monitor button to reopen it. Anyone else experiencing this?
Photo of Edward Schempf

Edward Schempf

  • 3 Posts
  • 0 Reply Likes
I have been having the same problem, with my 27" IMac and 2nd monitor. I keep my dock on the second monitor so that it is out of direct sight, but I don't have to wait for the hiding effect to come on to use. When I start LR the main screen with my library is always on my 2nd monitor. Sometimes to remedy it is as simple a moving that window to the IMac, and holding it there for a second, then the image screen moves to the 2nd monitor and the Library window stays on the IMac. Unfortunately, it doesn't always work and I have to play around to get it to move to the correct screen. I can't work from the second monitor because it isn't calibrated. If I could just assign in LR Preferences which screen I want LR to open on.