Lightroom 5.5 crashes repeatedly when marking photos for deletion in gallery mode.

  • 3
  • Problem
  • Updated 4 years ago
Version 5.5 installed last week. In gallery mode, when I am quickly going through and marking photos with an X for deletion, Lightroom crashes. I am not performing the actual deletion, just marking the photos. The crash occurs repeatedly.

I created a new catalog that contains two days of photos (softball games). Each game folder has about 2500-3500 photos. I delete a lot of them as I take multiple frames per second and only keep one of every 5 or 6 photos. This is a NEW bug introduced in 5.5. I have had Lightroom since 3.0 (and was on 5.4 prior to the upgrade) and I've never experienced this repetitive crashing problem. I believe it is related to how quickly I'm going through the photos and the database update necessary (Quad core, Windows 7, 16 GB RAM - only Lightroom and at times Photoshop are running). When I open Lightroom up again and return to where I was, it is only missing a couple of the deletion marks.
Photo of Robin Thompson

Robin Thompson

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 3
Photo of Kevin Henney

Kevin Henney

  • 1 Post
  • 0 Reply Likes
I'm having the exact same problem since installing 5.5. Repeated crashes while marking photos for deletion. It happens even on smaller folders (t changed - this same behavior caused no problems in past versions of LR.
Photo of daniel mcgarrity

daniel mcgarrity

  • 2 Posts
  • 0 Reply Likes
Same problem here-Windows 7 64 bit quad core 32 gb of RAM
Photo of daniel mcgarrity

daniel mcgarrity

  • 2 Posts
  • 0 Reply Likes
Wow, because the gallery is now upgraded to 5.5 I can't delete 5.5 and reinstall 5.4

Adobe, you are kind of being annoying on this