Lightroom 5.3 printing problem on MacOS 10.9.1

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
Hello,

The problem is with Lightroom 5.3 on an Apple iMac with OS X 10.9.1.

I try to print a packet of images on one A3+ paper, set up as a user defined format.

The result is only about 25% of the print being on the paper in a lower corner.

The image seems to be cut off at the right side and also a misplacemed by some ten centimeters. Also orientation is perpendicular to what was wished for. This has worked before ... .

The results are the same when I change paper preset from landscape to portrait orientation.

Also, when I try to replace images into cells the cells orientation and size changes even when "drehen und einpassen" (german for "rotate and fit") is selected.

Printer is an Epson 3880. I reinstalled the newest drivers and printing out of other programs is not a problem.

Man, this has cost me paper, ink and nerves. I meet my customers tomorrow evening. Printing every small image onto one large sheet is very expensive. Crap.

Photo of Markus Hoffmann

Markus Hoffmann

  • 1 Post
  • 0 Reply Likes
  • frustrated and really angry

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
Did this work correctly on your previous MacOS version?

Printing out of other programs doesn't mean much, since most programs use older print APIs than Photoshop and Lightroom.

Have you checked with Epson for updated drivers for MacOS 10.9? (they had quite a few bugs to fix).
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2588 Posts
  • 323 Reply Likes
Have you tried resetting your LR preferences?

Do things work if you try one of the standard page layouts?

Try printing with a image that consists of a few dots in the corners rather than a full tone image that'll waste ink.