Lightroom: LR 4 torrential lag when using spot removal or adjustment brush

  • 2
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
LIGHTROOM 4

I migrated from LR3. I never installed the beta because I didnt want to deal with BETA ISSUES. I wanted a product that worked as it should immediately out of the box. [Does ADOBE understand that???]

I BOUGHT LR4, installed it on my computer, updated the library, and then opened an image I had been working on but not completed in LR3. I clicked to update it to the newer processing and IMMEDIATELY there was torrential lag. My CPU Usage meter showed maxed out. I decided to reset the image and start from scratch. This worked for a very short time. As soon as I began using the adjustment brush the lag started building - the more I used it, the worse it got.

I then decided to open an image that had never been opened in LR3. Same issue. As soon as I started using the adjustment brush or the spot removal there was lag. and it got worse and worse the more I used it. Again my CPU meter showed maxed out. My RAM never jumped about 50% utilized though....

I am running:
Intel® CoreTM i7-740QM
nVidia GeForce GTX 285M 1,024MB PCI-Express GDDR3 DX10
8,192MB DDR3 1333MHz Dual Channel Memory
7200rpm serial ATA drives
Windows 7 64 bit OS
Photo of Keith Morgan

Keith Morgan

  • 7 Posts
  • 0 Reply Likes
  • pissed off

Posted 7 years ago

  • 2
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Official Response
The public RC build of Lightroom 4.1 was just posted on http://labs.adobe.com/technologies/li.... Please install and give it a try. If this problem persists, post back and let us know. More information is available at http://blogs.adobe.com/lightroomjournal/.