Lightroom 4 slow and crashing

  • 3
  • Problem
  • Updated 4 years ago
Lightroom 4 runs very slowly in develop module, very juddery nothing is smooth sliders resizing, brush tool etc. and also keeps crashing
Photo of T

T

  • 8 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 3
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
See: http://feedback.photoshop.com/photosh...

Is this related to what you are seeing?
Photo of T

T

  • 8 Posts
  • 0 Reply Likes
Yes John, thanks for the link unfortunately it looks like Adobe hasn't fixed the problem yet. Shame they didn't do more testing before they released it. Would have saved them a lot of embarrassment and us a lot of frustration.
Photo of Geoff Walker

Geoff Walker, Champion

  • 210 Posts
  • 37 Reply Likes
Have you tried Lr4.1RC2 available from Adobe Labs?
Photo of T

T

  • 8 Posts
  • 0 Reply Likes
No Geoff, but looking at some of those who have its not made much difference, is that correct?
Photo of Geoff Walker

Geoff Walker, Champion

  • 210 Posts
  • 37 Reply Likes
No, it really has made a difference for most. I am using it and while there are still some issues (2nd monitor lag, etc) performance is very good. Mind you I haven't had the issues others have, no rhyme, no reason!!
Photo of

  • 3 Posts
  • 0 Reply Likes
Of course, the first I've heard of 4.2 RC is here in this thread. That's a shame Adobe.
I'm running 4.1RC but wouldn't being informed that 4.2 is out. Brother.
Photo of T

T

  • 8 Posts
  • 0 Reply Likes
I'm just downloading LR4.1RC2 so we'll see how it runs
Photo of T

T

  • 8 Posts
  • 0 Reply Likes
Well LR4.1RC2 does seem to work better but still slow in develop especially when working at 100% doesn't move smoothly when navigating around image, but much better than LR4 it hasn't crashed yet either