Lightroom 4 - rename folder error

  • 3
  • Problem
  • Updated 8 years ago
This still doesn't work properly in LR4, tried both Windows Vista & Windows 7

There are a couple of - relatively easy to reproduce - cases where LR apparantly keeps a handle to a folder(search) or file, which prevents LR from renaming the folder.

This usually happens when you have a file selected in LR in the folder that you're trying to rename, which is not uncommon ;-)

(TECHNICAL NOTE: the problem is likely caused by the fact that another Lightroom thread is trying to load the image in the folder that is being renamed - the load thread is agnostic of what the file operation thread is doing)

You can "avoid" the problem by quickly selecting another folder in LR, while LR is trying to rename the folder.

This does make for a nice mini-game, but it gets old after a while ;-)
(yes, I'm sure I am not running any other software - including Windows Explorer - that references the folder or a file in the folder)
Photo of Lambert Wolterbeek

Lambert Wolterbeek

  • 19 Posts
  • 2 Reply Likes
  • depressed that the multi-threading architecture of Lightroom is so buggy

Posted 8 years ago

  • 3
Photo of Gerald Rowe

Gerald Rowe

  • 8 Posts
  • 1 Reply Like
This has been around for a long time ... it's really frustrating